WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Strange Header Image Problem (3 posts)

  1. SIBW
    Member
    Posted 5 years ago #

    I have my header set up so the background image (the header) is a clickable link. Well, I don't know if thats important for you to know. The problem is:

    The header that has the link over it displays on the home page every time, and when I click on an individual post the header displays as normal. But, if I then refresh that single page, the header image disappears.

    Its weird because the header is seperated into two areas, a 600px wide part then a 200px box next to it. The box appears every time. But when I refresh just the 600px background image disappears, and it is this area that has the link over it. That's why I'm thinking that might be to blame.

    But then again, it works fine on the homepage...

    Site is: shouldibotherwith.com

  2. SIBW
    Member
    Posted 5 years ago #

    You have no idea how much I hate coding.

    I changed the link from a background image to just an image withing the <div> - so was just a normal image with a normal link. And it works, obviously.

    But now, the sidebox (which needs to be a background image because there's stuff on top of it) does the same damn thing the other image was doing. It was fine before.

  3. SIBW
    Member
    Posted 5 years ago #

    I think, and this is just an educated guess, that it was something to do with an error message I received shortly after posting this problem (for no apparent reason):

    Warning: Cannot modify header information...

    After fixing that problem (extra spaces/lines at the end of functions.php) the background image problem seems to have gone with it.

    So...i'm a genius, you all suck.

Topic Closed

This topic has been closed to new replies.

About this Topic