WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Strange Comments Getting Added When Posting (9 posts)

  1. randyphillips
    Member
    Posted 3 years ago #

    The last few blog posts I've published I've noticed that a strange comment gets added to a previous blog post. The Title of the new post is the Author of the comment, the server where WP is hosted is the IP address, and a truncation of the first sentence of the new post is the comment itself. The comment seems to be on the same previous post. Very bizarre.

    Any ideas?

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems?

  3. randyphillips
    Member
    Posted 3 years ago #

    Thanks for your reply. I don't have any plug-ins enabled. Also, I don't see how the Theme would matter when posting an article from the wp-admin. The themes only come into play on the public site, not sure how one would cause this behavior on the back end.

    I've looked at the mysql records in the wp_comments table for these strange comments and the user id is the default value of 0 (when no user id is supplied). One would think that the creation of a comment would require the presence of a user id. So that's a problem in and of itself IMO.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Themes can, and do, affect all parts of WordPress - including the Admin area.

  5. randyphillips
    Member
    Posted 3 years ago #

    According to the docs ...

    A Theme modifies the way the site is displayed, without modifying the underlying software.

    In any case, under no circumstance should a comment be allowed to get inserted into the wp_comments table without a user_id present IMO. That's more than a flaw in the Theme.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Not all themes are coded according to the Codex, unfortunately. Or plugins for that matter.

  7. cuban_cigar
    Member
    Posted 3 years ago #

    It sounds like a mystery is afoot.

    * backup database
    * try default theme
    * update wp

  8. randyphillips
    Member
    Posted 3 years ago #

    Another detail I just noticed. This issue occurred with only two posts. Both posts had linkbacks to the post where the weird comment appeared. I've posted several other articles since then with no problems. The posts had no linkbacks though.

    At this point it's not a critical problem but more of a curiosity. Maybe this might trigger an idea on what is going on for a WordPress engineer.

  9. randyphillips
    Member
    Posted 3 years ago #

    Well, reading the docs on Trackbacks and Pingbacks this is evidently what Trackbacks do and why they are criticized.

    So the solution is to uncheck "Allow trackbacks and pingbacks on this page" when doing an internal links back to a previous post.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags