WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
Strange Code Added to .htaccess File (5 posts)

  1. heyya
    Member
    Posted 1 year ago #

    Several weeks ago I pasted 2 IP addresses in the “Ban User Agent” section of the plugin. Every day “\” are added to the left of the decimal. I deleted everything in the section and it broke the site.

    It added this to my .htaccess file. Take a look here to see a screen shot.

    Any suggestions on how to delete the IP’s?

    Thanks.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. heyya
    Member
    Posted 1 year ago #

    It seems these 3 lines are giving me problems

    RewriteCond %{HTTP_USER_AGENT} [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} [NC]
    RewriteRule ^(.*)$ - [F,L]

    The lines look like this, but with a lot more /
    RewriteCond %{HTTP_USER_AGENT} ^188\\\\\\\\\\\\\\\\\\\\\.143\\\\\\\\\\\\\\\\\\\\\.233\\\\\\\\\\\\\\\\\\\\\.30 [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} ^49\\\\\\\\\\\\\\\\\\\\\.156\\\\\\\\\\\\\\\\\\\\\.143\\\\\\\\\\\\\\\\\\\\\.2 [NC]
    RewriteRule ^(.*)$ - [F,L]

    I'm not sure why it's continually adding lines of code.

  3. MickeyRoush
    Member
    Posted 1 year ago #

    I don't believe you should put and IP Address in for a User Agent.

    http://en.wikipedia.org/wiki/User_agent

  4. Netz
    Member
    Posted 1 year ago #

    Hi,

    same problem here...
    I keep getting strange NON ascii or so in my .htaccess and get a server 500 error...
    I have now tested since oct. 2012 (almost 4 month)
    I thought it was all the other plugins... - But no!

    I have 6 blogs with this on.. All 6 fails from time to time??
    All is updated
    Not very nice for security??!!
    Any ideas? / Help or alternative?

  5. Netz
    Member
    Posted 1 year ago #

    Hi again!

    I remembered that in Tweaks there was an option to STOP Better WP Security access to write to core files including the htaccess file...
    So away I went... And un-ticked the box!

    So at least I could wait for someone in this forum to help me out!

    But as I was finishing up the last BLOG! It happend again???
    To the first blog that was "done"... B-WP-S had no rights to write to the file... and yet it happend!?

    So I have maybe placed this topic in the WRONG forum... Maybe IT IS NOT B-WP-S plugin that are causing this?? - Sorry lads!

    I have requested some SERVER logs from my host - I now have some time-slots to look at!! LOL
    I will find the plugin... and it WILL be terminated and the author will feel my "Woodoo" :)

    Nite nite folks!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.