WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Strange Bug: Can't edit; Keep being redirected to slug (18 posts)

  1. ch0de
    Member
    Posted 8 years ago #

    I cant edit no post. if I click edit, It loads the toolbar and the page and redirects me to the slug. What the heck?

  2. ch0de
    Member
    Posted 8 years ago #

    Fixed.

  3. Mark (podz)
    Support Maven
    Posted 8 years ago #

    How ?

  4. wozy
    Member
    Posted 8 years ago #

    I encountered the same problem, with WP 2.0 RC1, RC2 and RC3 installed today. I once disabled all my plugins and the problem was still there. ch0de, or someone else, who can tell me how to fix this strange problem? thanks in advance.

  5. AleXP
    Member
    Posted 8 years ago #

    AS far as I found out, a few people do have this problem - no matter if they use customized versions or not.

    So chode, please, post your solution and not only "fixed".

  6. vkaryl
    Member
    Posted 8 years ago #

    Well, I had the problem as well, but it "fixed itself" after I installed "one more plugin" - UTW....

    I'm not trying to be funny. That's exactly what happened. This is on 2.0 beta 1, and no, I have NOT upgraded, nor am I going to any time soon (not even to the release version when it happens): this is a clear case of "if it ain't broke, DON'T FIX IT. This version is working perfectly - since it "fixed itself". End of story.

  7. wozy
    Member
    Posted 8 years ago #

    I also used UTW, but not lucky as vkaryl.

  8. abrazell
    Member
    Posted 8 years ago #

    beta 1 is broke. :-) That's why there are newer versions. :-)

  9. vkaryl
    Member
    Posted 8 years ago #

    Yup. But this one little thing for me is now fixed, and I'm not willing to deal with all the other stuff that's now being problematic....

    But that's just moi, you know. Others of course opt differently.

  10. vkaryl
    Member
    Posted 8 years ago #

    I did finally update to RC3 - which immediately produced this problem again. This time I deactivated all the plugins (verified that it worked without them), then reactivated one at a time until it quit working again.

    The culprit is SEM Frame-Buster in my install specifically. YMMV.

  11. Matt Mullenweg
    Troublemaker
    Posted 8 years ago #

    Ah yes, with the live preview a over-enthusiastic frame buster might bust you out of your own site.

  12. vkaryl
    Member
    Posted 8 years ago #

    Gosh - what an interesting comment....

    Btw, happy holidays of whichever version is your preference, to you and all the dev team, and your families.

  13. wozy
    Member
    Posted 8 years ago #

    Thank Matt. So can you fix this matter, or can I just turnoff the live preview function?

    BTW, Merry Christmas to all here.

  14. Mazalien
    Member
    Posted 8 years ago #

    I had the same redirection problem. I removed in posts.php

    the following lines (lines 83 t/m86) to deactivate the i-frame :

    <div id='preview' class='wrap'>
    <h2 id="preview-post"><? php _e('Post Preview
    (updated when post is saved)'); ?> <small class="quickjump">

    <?p hp _e(' edit ↑'); ?>

    </small></h2>
    <i frame src="<?php the_ perm alink(); ?>
    " width="100%" height="600" ></iframe>
    </div>

    and installed the preview plugin of Martin Chlup├í─? at :
    http://fredfred.net/skriker/index.php/jaeaa-preview/

  15. AleXP
    Member
    Posted 8 years ago #

    Wow. Thanks Mazalien!

    I finally found the problem: I was using a redirection script and forgot about it a long time ago.

    Whenever the page preview inside die iframe loaded, it redirected me to the post itself. Damn, am I stupid.

  16. Mazalien
    Member
    Posted 8 years ago #

    AleXP the remedy may be worse than the disease. I liked the idea of such a preview-pane very much. Its a pitty that it causes such errors. I hope the developers are goin to investigate this problem and come up with a brilliant insight.. :)-

  17. AleXP
    Member
    Posted 8 years ago #

    Well, actually the preview pane was not causing the error. It was the java-script inside my header.php, that was meant to do that - very successfully indeed.

    I don't know of a solution else than disabling all scripts when loading the preview. You don't really need javascript working in your preview page anyways, at least I don't.

    So maybe you could consider this to be a design error. Maybe there is also another reason for the edit page reloads, I personally fixed it by removing the <head>-script.

  18. larsboelman
    Member
    Posted 8 years ago #

    I recently upgraded from WP 1.5.2 to WP 2.0 and just found out that I can not edit pages anymore. I have tried both Firefox 1.5 and Safari 2.0.3 (on Mac OS X 10.4.4), but they give the same problem: only the preview pane is displayed and a link to 'edit', but this link does not work. I tried disabling Java and Java Script in both browsers, but with no positive result.
    It is as if the page is not parsed completely, since the HTML source ends all of a sudden when I view the source in either browser.

    I have no active plugins in my WP 2.0 install (I removed all of them actually from the wp-content/plugins/ directory to try to solve this problem). The only not-default thing I am using is the Letterhead 1.0 theme. This does not seem to be the cause of the problem either, since the problem also occurs when I switch to the default theme.

    Is this a common problem or am I the only one? I could not find other references in the WP Support forums than this thread. If I missed a thread, please mention it. All suggestions are appreciated. Thanks.

    ---
    I am not a fan of all these Java scripts and this WYSIWYG stuff in the new version and consider the preview pane a waste of desktop space. It would be great if there was some option to just disable that all. Thanks for the comment above with the lines of code to remove from the post.php file.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.