WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Strange Behavior making lists in the visual editor (5 posts)

  1. spencerdahl
    Member
    Posted 1 year ago #

    In 3.4.2 when I make a list using the visual editor I get:

    <ol>
    	<li>Apple</li>
    	<li>Oragange</li>
    	<li>Grape</li>
    </ol>

    In 3.5-RC6-23166 I get:

    <ol>
    	<li><span style="line-height: 1.714285714; font-size: 1rem;">Apple</span></li>
    	<li><span style="line-height: 1.714285714; font-size: 1rem;">Orange</span></li>
    	<li><span style="line-height: 1.714285714; font-size: 1rem;">Grape</span></li>
    </ol>
  2. There were still HTML spec changes happening last night. Have you re-tried this scenario on the now-released 3.5?

  3. Caspar
    Member
    Posted 1 year ago #

    I see a similar (mis)behavior in 3.5-released where TinyMCE randomly adds a <span style="line-height: 1.714285714; font-size: 1rem;"> at the beginning of a new paragraph. It is hard to really nail what actions exactly precede the behavior, but it seems the editor chokes on the mix of new paragraphs (return key) and single line-breaks (shift+return) when text that already has been entered is being re-formatted.

  4. Caspar
    Member
    Posted 1 year ago #

    That's a fresh 3.5 and Twenty Twelve, btw.

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    @Caspar: Please post your own topic. WordPress 3.5 is no longer in beta.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags