WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] stranege footer position problem (8 posts)

  1. erwin_m
    Member
    Posted 1 year ago #

    Hy, I'm building a template based on twentyten. My footer is on every template on his place except the category page, there the footer is below the wrapper. I've bin trying and trying, but I don't know any anymore.
    Can anyone help me please?

    Thanks for thinking with me!

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Resolve the unclosed errors from the W3C Validator.

  3. erwin_m
    Member
    Posted 1 year ago #

    I've looked at them, but for me none of these errors make sense causing my problem. If it does to you, which wouldn't surprise me, I would like to hear suggestions.

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Try deactivating plugins to explore whether any could be responsible.

  5. erwin_m
    Member
    Posted 1 year ago #

    Doesn't make any differnce.

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    If you look at the HTML for the home page, it shows the footer inside the wrapper:

    <div id="wrapper" class="hfeed">
       <div id="access" role="navigation">
       <div id="socmed">
       <div id="header">
       <div id="main">
       <div id="footer" role="contentinfo">
    </div

    But on the category page, the footer is below the wrapper closing tag:

    <div id="wrapper" class="hfeed">
       <div id="access" role="navigation">
       <div id="socmed">
       <div id="header">
       <div id="main">
    </div>
    <div id="footer" role="contentinfo">

    I'd go back and look at those validation errors for tags...

  7. Andrei Olsen
    Member
    Posted 1 year ago #

    You've got one too many of </div> in your sidebar. That's why the browser thinks footer-div is outside the wrapper-div.

    Look for the code that generates

    </div></div>
    </li></ul>
    </div><!-- #primary .widget-area -->

    and remove one </div> right before </li></ul>.

    The easiest would probably be to search your php files for <!-- #primary .widget-area -->.

    Secondly, you have an issue with a couple of links. It's your social media icons on the top (facebook, twitter, etc.). Should be target="_blank" not target=_blanc" (note " after the = and letter k instead of c). This won't affect the layout, but still something that you should fix.

    You can safely ignore the rest of the errors.

  8. erwin_m
    Member
    Posted 1 year ago #

    Andrie, you're the best! I've coded he sidebar my self in a textwidgetwith a bit copy and paste from dreamweaver, at some point I've missed a /div with overwriting, I think.

    It works, thanks to you all!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.