WordPress.org

Ready to get started?Download WordPress

Forums

"Store Uploads In This Folder" Gone... Why? (7 posts)

  1. Milo Bozovich
    Member
    Posted 1 year ago #

    Yea, so after installing the new wordpress for a couple of my clients. I see the "store uploads in this folder" option has been removed from WordPress 3.5... my question is why and how can i bring it back? spreading downloads across multiple nameservers increases site speed and now with this change it's no longer possible without making my job much more difficult..

    So I guess my question is, why would WordPress remove this option and how can I bring it back? Seems pretty pointless to make an update if it's going to limit peoples options instead of adding new ones.

  2. RitaLorraine2
    Member
    Posted 1 year ago #

    I agree. My problem is not quite the same, but it's similar. When I upload images, I can see them in the media library, but for some reason, the file path is wrong. So the picture never shows in the post that I assign it to because the path is wrong. And now that the "Store Uploads in This Folder" option is gone, I can't figure out how to correct this or where to go if I do figure out how to correct it.

    Please help!

  3. criss266
    Member
    Posted 1 year ago #

  4. mpar
    Member
    Posted 1 year ago #

    WordPress flexibility is what made it so popular. Now removing "media location folder option" is a big No No. Don't fix it, if it ain't broke. There is nothing worse than a software that tries to control your life.
    Please add "Store uploads in this folder" field to the Media Settings page. I will not use WP 3.5 until it is practical as it used to be! Or maybe I should create a Plugin to do it for me!

    Thank you WordPress Team!

  5. Milo Bozovich
    Member
    Posted 1 year ago #

    I feel your pain...

    For this interested in still using this option, simply download WordPress 3.4 implement it on that, and then upgrade to 3.5.

    If you do that the option will still be available in 3.5. otherwise it won't show up.

  6. mprewitt3abn
    Member
    Posted 1 year ago #

    There is a workaround explained here: http://www.wpbeginner.com/wp-tutorials/how-to-change-the-default-media-upload-location-in-wordpress-3-5/

    It involves adding a directive to your wp-config.php, like so:
    define( 'UPLOADS', 'wp-content/'.'files' );

  7. morespinach
    Member
    Posted 1 year ago #

    That workaround does not work. Forcing it in the config file still does now allow me to change how the URL gets written by WP, only where the files are stored.

    In the past, I could specify the folder, and then also specify the URL prefix. This allowed me to use CDN services just fine, with "origin pull".

    Any idea how to do this? Thanks!

    (This has got to be one of the most idiotic "choices" by WP. Really can't fathom any intelligent reason for this.)

Topic Closed

This topic has been closed to new replies.

About this Topic