WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] Stopping YARPP displaying on Home Page (12 posts)

  1. Mycenius
    Member
    Posted 1 year ago #

    Hi - I'm returning to using YARPP but only want it to display on the full post page, and not on the "read more" (i.e. the "More" Tag) abbreviated post entry on my home page. The older version I was using 12-18 months ago did this OK but the latest version appears to display everywhere (i.e. it's in the 'footer' section of the post not at the end of the content so the 'read more' insert doesn't hide it)?

    I did a search but couldn't find a post that seemed directly related - so apologies if you do have a discussion of this already somewhere.

    Oh, and FWIW I had already upgraded to WP 3.5 before I decided to return to using YARPP, so can't advise if the latest WP upgrades are contributing to the issue?

    P.S. I have it disabled at present but can activate and post link to my site to illustrate if needed.

    Many TIA.

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. Ultra Violette
    Member
    Posted 1 year ago #

    Here's the answer you need, I had the same problem and it helped! :)
    http://wordpress.org/support/topic/no-thumbnail-just-stripes-how-to-get-custom-theme-to-work?replies=3

  3. Ultra Violette
    Member
    Posted 1 year ago #

    Oops sorry wrong link, let me find the right one

  4. Ultra Violette
    Member
    Posted 1 year ago #

  5. Mycenius
    Member
    Posted 1 year ago #

    Hi UV - Thank you for the responses - however neither of them seems to resolve the issue I have...

    Your second link appears to deal with the content of the related items list rather than it's actual placement - or am I missing something...?

    I have temporarily turned it on on my website so you can see the issue I am trying to deal with.

    http://wargaming.info

    :-)

    Appreciate the help and any further suggestions?

  6. Ultra Violette
    Member
    Posted 1 year ago #

    Ok maybe I didn't understand well what your problem is. You want the 'related posts' list to appear at the bottom of the full post page, not below the 'continue reading' tag on the front page, right?

    If so, you need to go to 'settings' > YARPP related posts > at the top of the page, it says 'Automatically display' > there select 'articles'. Make sure 'Also display in archives' is not selected. It worked for me! :)

  7. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    If you want to display it on archive pages but not on single post pages, unfortunately this isn't possible through the settings. You will have to turn off the "automatic display" options, and instead call the code related_posts(); in your theme's template for your home page.

    The settings Ultra Violette helpfully suggested unfortunately will make it display in both the single page display and the archive pages, which I don't think is what you want.

  8. Mycenius
    Member
    Posted 1 year ago #

    Hi UV - thanks - yes that was it - Doh! I had just instinctively ticked it on originally when I updated & reactivated it, but didn't think to try removing it!

    Hi Mitcho - thanks - UV's fix has solved by immediate issue. What I want is for it to display on all single 'post' pages (including archives) and ideally all static 'pages' - including any archived posts. I have tested it now and it seems to now be doign what I wanted so looks to be all good!

    Many Thanks to both of you.

  9. WP-SpamFree
    Member
    Posted 1 year ago #

    I have a similar problem. When I select automatically display on Posts with no other options selected, the related posts appear on my home page above the "continue reading" button. I don't want these to display on anything but the full post page. How do I change that?

  10. Mycenius
    Member
    Posted 1 year ago #

    Hi WP-SF - as per UV's original note to me, assuming you have not done the custom template coding and are using YARPP 'as is' to automatically insert the code. You need to set as follows in the settings (this is assuming you have the latest version of YARPP installed):

    Line 1 (Automatically Display) - Tick "Posts", Don't Tick "Pages" & "Media" boxes
    Line 2 - Don't Tick (or Untick) "Display In Archives"

    Click "Save"

    Go to WP Super Cache Settings and delete (clear) your cache. Reload your homepage and all should be good.

    This works for me...

    Otherwise, if you have done the custom template thing and inserted the text manually you have probably inserted it in the wrong place...

    :-)

  11. jgpws
    Member
    Posted 5 months ago #

    Hello Everybody.

    I just installed this plugin for my blog that has a static page with "the latest post" at the top. I had this issue with Posts checked and everything else unchecked.

    After trying to figure out whether there was an issue with my custom loop on the front page, I decided that hiding it with CSS is easy and works well.

    In your theme's stylesheet where the static page's css is referenced (or if it is in a separate stylesheet), simply insert something like this:

    div.yarpp-related {
    	display: none;
    }

    This still loads the Related Posts on the front page, but hides it. Hope this helps.

  12. jgpws
    Member
    Posted 5 months ago #

    An update to the comment above is to make sure the body tag of the specific page is targeted, so it does not hide the related posts on every page. When a static page is set, the body class uses the home class.

    body.home div.yarpp-related {
        display: none;
    }

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic