WordPress.org

Ready to get started?Download WordPress

Forums

Stopping automatic <P></P> at Publish (5 posts)

  1. Seith
    Member
    Posted 7 years ago #

    Hia, I've completly edited my template into a personal one - and I was wondering where I make the program stop automaticly adding <P> and </P> when I publish a post/save it.

    It causes my Title to go weird =/ and even though I've looked I can't see where to edit (bit of a noob at PHP, but experianced enough to edit/update when I know where to look)

    Thanks for any help you can give, I did a search but couldn't find anything :(

    Cheers again,
    Seith

  2. Doodlebee
    Member
    Posted 7 years ago #

    Option 1 is to turn off the Visual Rich Editor. I'd start with that and see how well it works for you :)

  3. Seith
    Member
    Posted 7 years ago #

    I tried editing it in just HTML but as soon as it saves and reloads it adds them back in again =[

  4. Doodlebee
    Member
    Posted 7 years ago #

    Yes, but did you turn off the visual rich editor? If you don't, then it'll be there no matter how many times you save.

    You'll know you're using it when you can write posts using the little buttons above your writing area - you'll see like an image of a tree for inserting pictures and it'll have a button for aligning text and stuff. If you see that (rather than the plain quicktag buttons with just text in them) then you're using the rich editor. Turn it off, and you'll have to remove all the <p> tags and resave.

    If it's *still* doing it, then you need to open up your wp-includes/default-filters.php file and comment out all of the "wpautop" references.

    But start with the visual rich editor - you can turn it off in your "user" area, at the bottom of the screen.

  5. red-star
    Member
    Posted 7 years ago #

    You can also type your post in notepad or nodepad++(the last one is a real handy one) and then copy paste it into your writing section.

    This if you want to keep the rich editor..

Topic Closed

This topic has been closed to new replies.

About this Topic