WordPress.org

Ready to get started?Download WordPress

Forums

Duo Two-Factor Authentication
[resolved] Stopped working on MultiSite (16 posts)

  1. Bart
    Member
    Posted 1 year ago #

    After updating the WordPress Duo security plugin to the latest version, it stopped working on my multisite installations.

    I had the plugin network activated which worked fine with an older version of the plugin.

    When network activated the plugin doesn't show up in the plugin sections of the network sites. It did with the older version

    When I network deactivate it, it does show up, but when I chose settings, I get "You do not have sufficient permissions to access this page." Mind you I am both the network administrator and the administrator of all the network sites.

    I checked this on two network installations, they both worked with an older version of the plugin. Now Duo authentication just stopped working. It's now just the plain WP login procedure.

    http://wordpress.org/extend/plugins/duo-wordpress/

  2. snipeyhead
    Member
    Posted 1 year ago #

    I'm having the exact same problem as Bart. No errors - it just never takes me to the second screen during the login process, and acts as if the plugin isn't installed at all.

  3. Romanmm
    Member
    Posted 1 year ago #

    The same problem — WP 3.5.1 multisite.

  4. snipeyhead
    Member
    Posted 1 year ago #

    Hi Romanmm - when you go into the Duo Security settings, where you put your API key in, make sure there's something selected for the roles associated down towards the bottom of the page. There was a bug in the code that didn't set a sane default, and breaks if you don't set it manually. This is what fixed it for me, anyway.

  5. Romanmm
    Member
    Posted 1 year ago #

    I have the same problem as Bart — I can't even enter to Settings, I get "You do not have sufficient permissions to access this page."

  6. snipeyhead
    Member
    Posted 1 year ago #

    Which page are you trying to access?
    http://www.example.com/wp-admin/network/settings.php ?

  7. Romanmm
    Member
    Posted 1 year ago #

    http://example.com/wp-admin/options-general.php?page=duo_wordpress

    On Multisite plugins page I have no Settings button at all when I activate the plugin so I need to activate it per site.

  8. snipeyhead
    Member
    Posted 1 year ago #

    No, you won't find the global settings in a settings button - it's down at the bottom of the page on the general settings page. Try the link I posted (with your domain) and scroll all the way down - see if you see a section for DS on that page.

  9. snipeyhead
    Member
    Posted 1 year ago #

    (Also, if you haven't yet, try completely deleting and then reinstalling the plugin from scratch)

  10. Romanmm
    Member
    Posted 1 year ago #

    Thanks, snipeyhead, you're right. After settings page setup Duo started to work but only on main site. It works flawlessly but only on main site.
    Do you any idea what to do else?

  11. Bart
    Member
    Posted 11 months ago #

    @snipeyhead

    Thanks after reading your tip three times, I got it :-) It now works again for my two Multi site installs, both the Main site and sub sites.

    In this new situation I only have to add a multi site installation once. In the past I needed to add all sub sites one by one. This is a great step forward.

    I think it's not a great choice to put the DS settings on the general settings page. It would be much better to put them on a separate settings page like most plugins do. Also fixing the Duo Security "settings" link on the plugin page in the process would be great.

    For the rest I really love Duo Security, it got even better, with the added features, like bypassing two factor authentication for given IP's

  12. Romanmm
    Member
    Posted 11 months ago #

    Hi everyone,

    Duo support team checked my issue, I've also checked it on my new WP3.5.1 multi-site installation and all works flawlessly. I think on my old WP site there is a plugin that doesn't allow to plugin to work on all sites.
    So now I use Duo plugin for all my WP installations — it works.

    Regards,
    Roman

  13. snipeyhead
    Member
    Posted 11 months ago #

    Hi guys - sorry I'm late in responding.

    @Bart - I agree that's a very confusing place to put those settings. It took me forever to find those settings there. I hope the break it out into its own tab again soon. I don't work for them, but I've been in touch with their support folks, and I'll mention it to them.

    @Romanmm - glad to hear it's working again!

  14. Duo Security
    Member
    Plugin Author

    Posted 11 months ago #

    Glad to hear it sounds like everyone was able to find where the settings had been moved to in the latest version, so they could be configured globally for the WordPress MultiSite system instead of having separate integrations for each blog in the network.

    I will make sure your feedback gets back to our user experience team, though, as I understand this change was really confusing to some customers.

  15. Bart
    Member
    Posted 11 months ago #

    Thanks!

    It's much better to have in network setting. Network security is much easier to manage this way.

    A separate settings will be highly appreciated :-)

    Great to experience how DuoSecurity is evolving. Wouldn't want to swap it for any other solution :-)

    -- Bart

  16. Taylor4484
    Member
    Posted 6 months ago #

    For anyone else trying to figure this out, try this link:

    WP 3.6.1
    http://YOUR-DOMAIN-NAME/wp-admin/network/settings.php

    Scroll all the way to the bottom of this page, and you'll see the Duo Mobile settings.

    This is the 'Network Settings' page in your network admin "Settings" Menu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic