WordPress.org

Ready to get started?Download WordPress

Forums

Simple Lightbox
[resolved] Stopped working for me (6 posts)

  1. FirstTracks
    Member
    Posted 1 year ago #

    I've been using Simple Lightbox for a couple of years at http://www.FirstTracksOnline.com and I just noticed that it stopped working. Both WP and the plugin version are current.

    I've tried clearing the cache, using different browsers, etc. but the problem persists. Any ideas?

    http://wordpress.org/extend/plugins/simple-lightbox/

  2. Archetyped
    Member
    Plugin Author

    Posted 1 year ago #

    There may be a couple reasons why this occurring:

    First, something is loading a different version of jQuery than what is officially supported by WordPress (and thus by SLB). Removing/disabling the code that is loading the different version of jQuery would allow WP to load the correct version.

    Second, several JavaScript errors are reported when your site loads. Certain JavaScript errors can stop other JavaScript code from executing properly (such as SLB's image activation).

    My recommendation would be to disable all plugins (except for SLB) to see if SLB is once again functional. If so, then re-enable plugins one-by-one until SLB stops working. The plugin you enabled when SLB stopped working is the rogue plugin.

    If you've recently updated or changed your theme, it may also be a good idea to switch to WP's default theme while testing in case the theme is causing an issue.

    If SLB still isn't working with all other plugins disabled, let me know and provide a link and I would be glad to take a closer look.

    Thanks.

  3. FirstTracks
    Member
    Posted 1 year ago #

    Thanks, Archetyped. The problem plugin turned out to be Super RSS Reader, and your diagnostic suggestion located it. All is well now.

  4. Archetyped
    Member
    Plugin Author

    Posted 1 year ago #

    Awesome, glad to hear it!

  5. Obadiah
    Member
    Posted 1 year ago #

    I also noticed Simple Lightbox plugin wasn't working after updating to WP 3.5 or 3.5.1.

    Following your advice above, I found a different plugin was loading jQuery.

    After removing the jQuery inclusion code, Simple Lightbox seems to work fine!

    Thanks!

  6. Archetyped
    Member
    Plugin Author

    Posted 1 year ago #

    Naughty plugins...

    Glad you got it worked out :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.