WordPress.org

Ready to get started?Download WordPress

Forums

Stop WP from auto inserting tags (4 posts)

  1. nadine00
    Member
    Posted 2 years ago #

    WordPress keeps auto inserting a
    tag after an anchor link in the HTML editor, and it is driving me nuts. How do I get it to stop?

    example:

    <h2>Custom Event</h2>
    <a name="custom"></a>

    Thanks.

  2. nadine00
    Member
    Posted 2 years ago #

    Anyone? Bueller?

  3. bitkahuna
    Member
    Posted 2 years ago #

    edit functions.php, add this:

    remove_filter('the_content', 'wpautop');

  4. res401
    Member
    Posted 2 years ago #

    Try this plugin WP BR Tags. This will disable wpautop() from running.

    WordPress’s built-in post/text editor (TinyMCE), executes a back-end filtration process which removes empty tags, and
    tags from the post, when switching from the “Visual” to “HTML” tab in the editor in WordPress or vice-versa.

    WP BR Tags Allows you to insert [Short-Code] instead of <html> codes, the result is TinyMCE won't mess with your code, and You get to have Line Breaks where you want them!

    I hope this helps,
    Rich

Topic Closed

This topic has been closed to new replies.

About this Topic