WordPress.org

Ready to get started?Download WordPress

Forums

Stop white short of bottom (5 posts)

  1. trinker
    Member
    Posted 1 year ago #

    Apologies for the title; if you have a more fitting please fix it.

    I am using the twenty twelve theme and notices some people with the twenty twelve them are able to stop the white portion of the page about an inch from the bottom of the screen as seen here:

    http://twentytwelvedemo.wordpress.com/

    However in my page the white goes to the bottom:

    http://gsewebwp.gse.buffalo.edu/org/clari/

    How can I make the whait background stop an inch from the bottom to reveal the light gray background?

  2. W.P. Ginfo
    Member
    Posted 1 year ago #

    Hi Trinker,

    It already does - in a way.
    If you scroll down, using your mousewheel, you'll see there is an end to the page and the gray background is shown.

    What is shown on screen depends largely on the size and SETTINGS of the individual screen. To play around with it use <CTRL-'+' or '-'> to 'fit' the page.

    If however you would like to limit the height of pages: to force a fixed size display of pages, add a maximum height to the style.css of the childtheme of your site.

    Fixed height:

    body .site {
        height: 800px; /*adjust as required*/
        overflow:hidden;
    }

    Maximum height [or shorter]

    body .site {
        max-height: 800px; /*adjust as required*/
        overflow:hidden;
    }

    == == ==

    1. Install and activate 'one click childtheme plugin
    2. create and activate a childtheme
    3. Make the changes in the CHILDtheme!
      - copy php files / css-file(s) of the original theme [as required] to the childtheme directory and edit them as required.
  3. trinker
    Member
    Posted 1 year ago #

    W.P. Ginfo Thanks for your replay. You're right on with everything you say. Your solutions work unless the page content exceeds that length; it's cut off. So it seems to say if, from the top, longer than 800px cut. I'm wondering if there's a way instead to say from the bottom make sure this space exists. I know it's possible because when I installed this plugin:

    http://wordpress.org/extend/plugins/kerstner-foundation-footer/

    I had this behavior, except the page is for a university and the plugin advertises in the gray section (not allowed). I couldn't get rid of the advertisement so I got rid of the plugin but still want that behavior.

  4. W.P. Ginfo
    Member
    Posted 1 year ago #

    Trinker,

    It already does what you want - in a way.
    If you scroll down, using your mousewheel, you'll see there is an end to the page and the gray background is shown.

    What is shown on screen depends largely on the size and SETTINGS of the individual screen. In the browser: To play around with it use <CTRL-'+' or '-'> to 'fit' the page.

    >>>
    Your site already has a bottom-margin, resulting in a background that shows at the bottom of the page.

    !!!So the problem you describe doesNOT show here!!!

    I've checked with the following browsers: Firefox, IE, Safari [win] and Chrome.
    !!NOTE!! Should you use an old browser, please update!

    The ONLY way I can replicate this problem you describe, is on an IPAD.
    You should know, this is a 'feature' of the apple ipad.

  5. Andrew
    Forum Moderator
    Posted 1 year ago #

    Hi there, I think you need to add this to your Child Theme style.css file;

    body {
     height: auto;
     padding-bottom: 1in;
    }

Topic Closed

This topic has been closed to new replies.

About this Topic