WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
stop caching Mysite.com/random (1 post)

  1. bondigor69
    Member
    Posted 7 months ago #

    I have this code in my functions.php

    add_action('init','random_add_rewrite');
    function random_add_rewrite() {
           global $wp;
           $wp->add_query_var('random');
           add_rewrite_rule('random/?$', 'index.php?random=1', 'top');
    }
    
    add_action('template_redirect','random_template');
    function random_template() {
           if (get_query_var('random') == 1) {
                   $posts = get_posts('post_type=post&orderby=rand&numberposts=1');
                   foreach($posts as $post) {
                           $link = get_permalink($post);
                   }
                   wp_redirect($link,307);
                   exit;
           }
    }

    The plugin caches this Mysite.com/random and always shows the same post.

    How to disable that

    http://wordpress.org/plugins/w3-total-cache/

Reply

You must log in to post.

About this Plugin

About this Topic

Tags