WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Step 2 does nothing (5 posts)

  1. dsteiny
    Member
    Posted 8 years ago #

    Hi,

    When I try to install WP on Solaris 7 - PHP 4.3.3 - MySlq 4.0.13 - it gets to Step 2 and does not go further. It says it is creating the tables and never goes beyond. What am I doing wrong?

  2. petit
    Member
    Posted 8 years ago #

    You have created the database first with name and user/password?
    And changed the wp-config.php accordingly?

    If not, please do!

  3. dsteiny
    Member
    Posted 8 years ago #

    Yes I have. If I do not do that, it fails on step 1 with an error.

  4. dsteiny
    Member
    Posted 8 years ago #

    Ok, I figured it out.

    In wp-db.php there is some logic that gets the tables out of the database to see if they are there. On about line 167 there is a line:

    while($i < msyql_num_fields($this_result))

    which then calls mysql_fetch_field

    The query was correctly returning $this_result as empty, but for some reason when it made the call to mysql_num_fields, it was returning 1. When it got to mysql_fetch_field it silently died.

    I added the "if($this_result)" right before the "while" and now it works fine.

  5. rbaldoma
    Member
    Posted 8 years ago #

    I've just try what you say, but it doesn't works, It seems that all de database is created and tables too, but the second steps ends and didn't give me the admin password.

    Could you send me the wp-db.php to compare it to rbaldoma @ pesagrup.com ?

Topic Closed

This topic has been closed to new replies.

About this Topic