WordPress.org

Ready to get started?Download WordPress

Forums

Step 1 (4 posts)

  1. rkoftan
    Member
    Posted 9 years ago #

    I've setup MovableType quite a few times before, so I am mostly familiar with running CGI scripts, MySQL, and web server configuration.
    I've read over the other posts and I've confirmed I have the appropriate versions of
    MySQL (4.0.21-debug)
    PHP (4.x)
    Apache (2.0x)
    I've setup a virtual server on Apache.
    I've updated my internal DNS to point to the FQDN I'm going to use.
    I've added the PHP module to Apache.
    I've created a PHP.INI file in the PHP directory
    I've read the readme on PHP installation.
    I've created a database in MySQL and granted rights on the database to the user;
    I configured wp-config.php in the wp folder (seen below).
    blockquote
    define('DB_NAME', 'wp_takeluck_org'); // The name of the database
    define('DB_USER', 'wp_user'); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    blockquote
    You'll note that I have no password for my user. that's ok for now.
    Thinking I'm good to go, so i run the install.php
    I get the following (and more)
    blockquote
    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require('upgrade-functions.php'); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; ?>
    /blockquote
    After the above block, the word 'WordPress' in big blue font is shown, then we see
    hide_errors(); $installed = $wpdb->get_results("SELECT * FROM $tableusers"); if ($installed) die(__('
    You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.
    ')); $wpdb->show_errors(); switch($step) { case 0: ?>
    Welcome to WordPress. We’re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. Before we get started, remember that we require a PHP version of at least 4.1.
    and on and on it goes...
    Any useful suggestions are appreciated.
    Thanks,
    Ryan
    I *thought* I had it all together, but when I

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Are PHP and mySQL absolutely definitely able to talk to each other ?
    The FQDN has me lost though, as does the virtual server stuff.
    This is on a remote host?

  3. rkoftan
    Member
    Posted 9 years ago #

    podz,
    regarding 'PHP and SQL' talking - not sure i know how to test that. can you provide me with a test idea or script?
    regarding the FQDN: I have my own internal network, quite a few servers (mostly old PIII's , typically workstation class machines); along with that internal network comes the need for internal DNS, and so on. the virtual server stuff refers to the way that apache defines a web site on the server.
    thanks,
    ryan

  4. rkoftan
    Member
    Posted 9 years ago #

    forgot a critical configuration setting in the apache.conf file
    addtype application/x0httpd-php .php
    DOH!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.