WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Stats Gone (4 posts)

  1. bartmoss
    Member
    Posted 1 year ago #

    I had to disable and re-enable Jetpack, because it kept disallowing comments when I am logged in on my own blog account. It did solve that issue, but unfortunately it also seems to have COMPLETELY have reset my site stats - It just started from 0.

    Needless to say... this is confusing and very sad :( !

    I did use the same account as before to connect to WP.com...

    Any help would be appreciated (though I guess only an Automattic guy can really look into this).

    The blog in question is http://www.enderra.com/ and wp.com user is "nils".

    http://wordpress.org/extend/plugins/jetpack/

    PS: Jetpack version is 2.2.2

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    With Jetpack, your stats information is connected to a unique blog ID. Sometimes, if a site owner was using a development site or a different address when they set up Jetpack, disconnecting may create a new blog ID. When this happens, it may appear that your stats were lost.

    That's what happened on your site; it previously used a different site URL, enderra.blog.pandemonium.de.

    I have fixed the issue, and you should be able to get your Stats and Subscribers back by going to the Jetpack menu in your dashboard, and disconnecting / reconnecting to WordPress.com.

    Thank you.

  3. bartmoss
    Member
    Posted 1 year ago #

    Hi Jeremy,

    Thanks very much for your answer!

    Yes, it did use that url at the very beginning. It's been happily gathering statistics for a while since then though. I'd submit that this is bad design on the wordpress.com stats/jetpack side and should probably be improved in the future.

    Either way, unfortunately the fix did not take (I tried to reconnect as both enderra.com and http://www.enderra.com).

    Best wishes
    Nils

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Either way, unfortunately the fix did not take (I tried to reconnect as both enderra.com and http://www.enderra.com).

    Could you go to the Jetpack menu in your dashboard, and click once again on the "disconnect from WordPress.com" button in the top right corner:
    http://www.enderra.com/wp-admin/admin.php?page=jetpack

    Once you reconnect to WordPress.com, you stats should be back.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic