WordPress.org

Ready to get started?Download WordPress

Forums

Static Post Page display full posts (9 posts)

  1. countmarco
    Member
    Posted 2 years ago #

    Hello,
    I have a self hosted WP.
    Set a static front page (Home):
    http://www.officialicemen.com/home

    And a static page to host blog (News):
    http://www.officialicemen.com/home/news/

    I want the News (blog) page to display full posts. No matter what settings I've tried it only shows posts as excerpts.
    I've researched and tried every setting possible on the WordPress Settings->Reading menu. According to what I've read it should work.
    Currently my reading settings are-
    A Static Page selected
    Front Page: Home
    Posts Page: News

    Please help.

  2. alchymyth
    Forum Moderator
    Posted 2 years ago #

    I want the News (blog) page to display full posts. No matter what settings I've tried it only shows posts as excerpts.

    there are (possibly) no settings for that (unless your theme has theme options for that purpose);
    the posts page is probably using the index.php template; you likely need to change the_excerpt(); to the_content(); in this file.

    http://codex.wordpress.org/Function_Reference/the_excerpt
    http://codex.wordpress.org/Template_Tags/the_content
    http://codex.wordpress.org/Template_Hierarchy

    not sure how this is in Weaver II ...

  3. countmarco
    Member
    Posted 2 years ago #

    Thank you alchymyth.
    I will try your suggestion.

    BTW- I initially searched weaver ii support before implementing the static pages and according to their guide it should work:

  4. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    In Weaver II you can go to Main options/Posts specific/ Scroll down to excerpts and make sure Excerpt Blog Posts is not checked. Don't forget to save.

  5. scrambler
    Member
    Posted 2 years ago #

    Your problem comes from The settings you have in Reading Settings.
    In reading > Settings, you have static page selected which is good, but for Post page you need to select Nothing (shows -select-)

    If you do select something (you have news selected right now), then the post page uses WordPress default, and none of the Weaver II options work.

    You can read the FAQ from Weaver support site for more info
    http://weavertheme.com/controlling-your-home-page/

  6. countmarco
    Member
    Posted 2 years ago #

    Scrambler-
    I have read that page before I ever implemented my static pages and have since as well. The setting they (and you) suggest does not work for me. I have tried it yet again setting posts to nothing- "select"
    and the result is no blog feed at all!

  7. countmarco
    Member
    Posted 2 years ago #

    kmessinger-
    I have already looked at Main options/Posts specific/ and excerpts and Excerpt Blog Posts is not checked nor was it ever.
    Thank you though, was worth a try.

  8. scrambler
    Member
    Posted 2 years ago #

    I see you have now posted in the Weaver forum, so we can continue to solve this over there :)

  9. countmarco
    Member
    Posted 2 years ago #

    Thank you scrambler!
    Yes I see you are something of a veteran with Weaver : )

    I deleted my blog, installed it fresh, imported data from xml save and voila- suddenly the blog posts full in News!
    What is most perplexing is I only was able to get it working by selecting News under Page With Posts (not nothing- Select).

Topic Closed

This topic has been closed to new replies.

About this Topic