WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] static pages not displaying (12 posts)

  1. magicmummy
    Member
    Posted 3 years ago #

    Hi,

    I had created a website using satic pages (www.kidskingston.co.uk). I decided I would like to have blog posts as the front page, but leave the static pages.

    On my local install (so the live site is fine) I created post categories and then created a post and assigned it to a category then in settings->reading set "front page displays" to "your latest posts".

    And that is where it all went wrong. Now when you click on the navbar links to any of the static pages it takes you to the blog posts. I removed the blog posts and changed the settings->reading set "front page displays" to static. Interestingly it does display the home page but none of the others work.

    Clear as mud? Please help!

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    What are you using to create your navbar?

  3. magicmummy
    Member
    Posted 3 years ago #

    In header.php I used this line of code:
    <?php wp_pages_menu('sort_column=menu_order');?>

  4. magicmummy
    Member
    Posted 3 years ago #

    sorry that should read
    <?php wp_page_menu('sort_column=menu_order'); ?>

    does this help?

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    Your navbar is working fine for me.

  6. magicmummy
    Member
    Posted 3 years ago #

    Yes sorry, perhaps I wasn't clear but the link I have given is for the live system which is working fine. I made the changes on the local machine before going live with it (rather pleased I did too!). So just gave the link to give more of a context of what I am doing.

    I can't for the life of me think why adding posts would break the static pages. When I hover over the links they look correct (ie hover over "about" shows 'http://localhost/kidskingston/about/') but once I click on it I get the "Not Found" page.

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    Is mod_rewrite running on your local server?

  8. magicmummy
    Member
    Posted 3 years ago #

    hmmm I have no idea, I have mamp installed. How do I check that?

  9. esmi
    Forum Moderator
    Posted 3 years ago #

    Sorry - I've never used MAMP.

  10. magicmummy
    Member
    Posted 3 years ago #

    Hi esmi,

    Well thanks for taking the time though, I appreciate it. I'll have a poke around with mamp and see if I can work it out.

  11. magicmummy
    Member
    Posted 3 years ago #

    hmmm still no joy, I have changed the static page setting front page to different pages in the settings menu. When I do this these pages do come up correctly as the front page of the site.

    anyone?

  12. magicmummy
    Member
    Posted 3 years ago #

    ahah!
    Right so was problem with plugin wp e-commerce and me. I had installed and activated the plugin accross the as network admin. I think this was confusing the system some how.

    I have de-activated the plugin from the network admin dashboard. gone to the kidskingston dashboard and resaved the permalinks. This seems to have fixed it....

Topic Closed

This topic has been closed to new replies.

About this Topic