WordPress.org

Ready to get started?Download WordPress

Forums

StrapVert
[resolved] Static Pages are not showing up (6 posts)

  1. Anil Anvesh
    Member
    Posted 10 months ago #

    I installed strap vert theme last night. But the pages are not showing up it's displaying only a black bar.Here is the link to my blog http://www.etechknol.com/ kindly resolve it Asap.

  2. WP Strap Code
    Member
    Posted 10 months ago #

    By static pages I assume you mean the menu right?

    First of all you need to create your menus under Appearance >> Menus. Then you can add the menu to the menu location by checking the box at the bottom of that page.

    If however you have already created your menu then navigate to the Customizer and allocate the menu to the designated menu location under the Navigation section.

    Hope that helps.

  3. Anil Anvesh
    Member
    Posted 10 months ago #

    Sorry not that in wordpress we have option of creating pages right?
    In your theme below the logo it should show pages for example this is my page http://www.etechknol.com/about/ why my pages are not displaying in black bar below the logo?

  4. WP Strap Code
    Member
    Posted 10 months ago #

    You have to create menu items of your pages and allocate those to the menu location as instructed above. When you've done that your pages will appear just like in the demo :)

  5. Anil Anvesh
    Member
    Posted 10 months ago #

    Oh no this is insane why should I create menu. I there are many items under one item then we will create menu. I didnt see this option in any theme :(

  6. WP Strap Code
    Member
    Posted 10 months ago #

    Sir, this has been the case for a while and its a WordPress thing and not a theme thing.

    Under Appearance > > Menus you have to create a menu group then from the left pane you have to select the pages (by checking the box) you want in that menu group. Then save and at the bottom you will see the options to add that group to the location in the theme - you then check the box and save again and your pages designated to that menu group and linked to that menu location will show up in the menu bar.

    If however you had already created a menu group before them all you have to do is go in to Appearance >> Customizer and last from the bottom you'll see the Navigation bar. Click on it to open it and in the dropdown select your menu. Once again save and view your site and you should see the menu items.

Reply

You must log in to post.

About this Theme

About this Topic

Tags