WordPress.org

Ready to get started?Download WordPress

Forums

static pages (17 posts)

  1. mattg
    Member
    Posted 9 years ago #

    I have been messing with the static pages and so far they have been quite nice. The only thing is that you don't seem to be able to edit the pages once you have created them. Everytime you try to edit, a new page is created. The cause looks like it comes from the form action which is always set to post on edit-page-form.php.
    For myself, I just fixed the problem by creating a new case in post.php to deal with the editing of static pages. Also, I moved the setting of the $formaction variable into the case statements on post.php instead of edit-page-form.php as well as added the post_ID to the edit-page-form.php.

  2. NuclearMoose
    Member
    Posted 9 years ago #

    http://mosquito.wordpress.org/ would be a good place to report this, Matt! :)
    Thanks.

  3. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    Fixed.

  4. womby
    Member
    Posted 9 years ago #

    And there was me thinking it was a feature that would get a better ui later.

  5. timeistight
    Member
    Posted 9 years ago #

    I'm having a bit of trouble understanding how these pages are "static". Aren't they served out of the database like everything else?
    Also, it doesn't look like you can insert PHP on these pages, can you? Or am I missing something?

  6. Anonymous
    Unregistered
    Posted 9 years ago #

    I don't know what you are talking about I installed the latest version and I don't see that problem.

  7. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    The UI will be changing.
    These aren't statically served pages; think of them as "standalone" pages. We don't call them "static" anywhere in the UI. We simply call them "Pages" as compared to "Posts".
    Pages don't allow php code unless you install the appropriate plugin. Pages are meant for "About" pages and the like, not for templates.
    Currently, you have to go to Options->Permalinks and click "Write mod_rewrite rules..." to get the new /site/ rules in .htaccess. The permalink and mod_rewrite stuff for pages will be evolving.

  8. Muffinboy
    Member
    Posted 9 years ago #

    Okay, yes, no they aren't really static pages, but I hope to use them to replace the static pages on my site. And yes, I had run the upgrade script.
    Anyway, I hit a couple of small problems:
    1) I already had a functioning htaccess file. I went into Options > Permalinks and hit 'Update Permalink Structure.' Then I clicked the 'Write mod_rewrite rules to .htaccess' button. Something must have gone wrong, but that caused on Error 500's on my whole /wp/ directory. I put a new, empty .htaccess file in the /wp/ dir and repeated the above actions, then everything worked well. After that I haven't been able to repeat the problem.
    2) The "Pages" generated right now look exactly the same as a normal, single post. The way I see it, it's of little use to have "about" information under a specific date and neither is it very useful to have specific post time printed out for it.
    What would be a great solution if for each Page you could specify a separate output template and css file.
    3) I don't yet have control over where the Pages end up, they always go in the /wp/site/ directory and I think it would be really useful if they could be 'placed' in other directories too. I'm thinking especially about a site layout like this:
    /index
    /blog/
    /topic1/
    /photos/
    /about/
    It would be very practical if WP Pages could handle all these locations, including the site's root index page, while the WP blog index would still be in the /blog/ directory.

  9. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    1) Fixed in CVS.
    2) If you put page.php in wp-content/ it will be used for displaying pages. Or, you can add is_page() code to your index.php. The new default template, once completed, will handle pages.
    3) That's planned.

  10. Anonymous
    Unregistered
    Posted 9 years ago #

    quote
    1) Fixed in CVS.
    2) If you put page.php in wp-content/ it will be used for displaying pages. Or, you can add is_page() code to your index.php. The new default template, once completed, will handle pages.
    3) That's planned.
    end guote
    Can you please explain that. Can I just run the upgrade.php and do that? When I got to page.php or the page code what will that do?

  11. Muffinboy
    Member
    Posted 9 years ago #

    @anonymous: This is new functionality planned for version 1.3. You can download a nightly and try it out, but I suggest you don't replace your working WP installation. Rather, put it in another directory and use a different database or different table prefixes, unless you are willing to play with alpha state software. In any case, make a back-up!

  12. Muffinboy
    Member
    Posted 9 years ago #

    @Ryan: great! Thanks :)

  13. Anonymous
    Unregistered
    Posted 9 years ago #

    rboren:
    Not fix in CVS
    you can see double slash adress recent CVS. like
    http://yourhomedns/wordpress//site/testpage
    also, tracback uri and other special - like previous/next - permalink showed double shlah or 404 error.

  14. Anonymous
    Unregistered
    Posted 9 years ago #

    I do have a the alpha in a test blog, not the main blog. I went through every file and don't see a page.php. And I tried the page setting and created a new page. It just shows as p=300static1 or something like that. I don't see a /wordpress/site/about url. Where is everyone getting that?

  15. Beel
    Member
    Posted 9 years ago #

    Anon: I will make this quick as my last attempt was interrupted by a reboot... There is no page.php, you write it and the blog header includes it if it exists. I don't have the slash issue so perhaps it crept into your blog and needs to be corrected in the database (or is something in the .htaccess).
    I just made a test page at http://www.billhayes.us/wordpress/site/about

  16. Anonymous
    Unregistered
    Posted 9 years ago #

    How did you set it up to do that?

  17. Anonymous
    Unregistered
    Posted 9 years ago #

    Never mind, I did it ;). I put a blank .htaccess file into my wordpress folder. It now work.
    http://www.chanistheman.com/wordpress/site/Downloads
    http://www.chanistheman.com/wordpress
    That is my test blog for the 1.3 wordpress. It is temp.
    My main blog is http://www.chanistheman.com/blog

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.