WordPress.org

Ready to get started?Download WordPress

Forums

Static page with Zbench theme - two home links (4 posts)

  1. paul1200c
    Member
    Posted 2 years ago #

    I have followed the instructions to create a static front page:

    http://codex.wordpress.org/Creating_a_Static_Front_Page

    I now have two home links in my menu bar but cannot find the navigation bar code to correct this, as per the instructions below:

    "To remedy this, edit the appropriate template file featuring the code of the navigation bar with the template tag wp_list_pages. In 99.9% of WordPress themes, this is the header.php file. Set the parameters to change the link title. In some cases, commenting (disabling) or removing the the line in the theme's code that displays the 'Home' link will do the trick."

    Can anyone help me find the relevant file/code?

    [No bumping, thank you.]

  2. pshankland
    Member
    Posted 2 years ago #

    Hi, I have the same issue and not sure what part of the header.php file I should be editing to remove one of the two home pages after creating a static page.

    Can someone help??

    Thanks.

  3. pshankland
    Member
    Posted 2 years ago #

    Edit header.php and delete the following:

    <ul><li<?php if (is_home()) echo ' class="current_page_item"'; ?>><a href="<?php echo home_url('/'); ?>"><?php _e('Home', 'zbench'); ?></a></li></ul>

    Thanks to the theme author for this.

    Pete.

  4. kbat82
    Member
    Posted 2 years ago #

    Are you editing this as a child theme? If so, you can edit your style.css to include:

    #menus ul:first-child{
    	display: none;
    }

    The other option is to do as pshankland mentioned. Although, I would also suggest you do this under a child theme as well, in case you have to upgrade your zbench theme in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic