WordPress.org

Ready to get started?Download WordPress

Forums

Static Page help (7 posts)

  1. VivaGardner
    Member
    Posted 4 years ago #

    So, I love your theme. I noticed in the new version you removed comments and date from pages. I figured out how to add the comments back into the page.php (just remove those two slashes on page.php before comments_template ---no date displayed, just the comment box).

    Is there a way to just allow the comments on a single page? I have a photo gallery page that I'd like to allow comments on.

  2. Shane G
    Member
    Posted 4 years ago #

    Hi,

    You can disable comment for your blog and enable for a single post while writing the post and in that window discussion box you can get the option to enable comment and pingback/trackbacks..

    Thanks,

    Shane G.

  3. VivaGardner
    Member
    Posted 4 years ago #

    It doesn't matter if the comments are enabled on the post, it has been removed from the lightword theme. That's why I'm wondering if there is another way to add comments to a single page? I still want my comments to be there for the posts, just I only want comments on a single page I made/

  4. andreiluca
    Member
    Posted 4 years ago #

    Hello,
    Just uncomment that line (like you said) and disable comments from wp-admin for the rest of the pages.

  5. VivaGardner
    Member
    Posted 4 years ago #

    Thanks for the response, but none of these solutions are working for me.

    Maybe I'm not being clear about what I want. If I uncomment page.php, comments will show on all the pages and posts. With the original page.php, no pages have comments.

    I want to still be able to have comments on my posts and I want comments on this SINGLE page.

    I understand and have set it up so comments are just enabled on that single page, HOWEVER, all my other pages still say 'NO comments' at the bottom after I uncommented page.php

    andreiluca, what I'm trying to do is to be able to remove the comment section from all my pages except one. Maybe it isn't possible what I'm asking

  6. VivaGardner
    Member
    Posted 4 years ago #

    I solved my problem.

    I simply uncommented page.php, so that comments were renabled on all PAGES.

    I then went into comments.php and edited line 6 to not say 'No Comments'

    So now, I have nothing on pages where I have disabled comments.

  7. andreiluca
    Member
    Posted 4 years ago #

    Hi,

    More elegant solution:
    Open page.php with a text editor, find this line:

    <?php comments_template(); ?>

    Replace with:

    <?php if ( comments_open() ) : comments_template(); endif; ?>

    Also fixed in 1.2.5

Topic Closed

This topic has been closed to new replies.

About this Topic