WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Static home page not showing 3.1 (34 posts)

  1. Eugen Oprea
    Member
    Posted 3 years ago #

    I am not sure how I got myself with the 3.1 beta version installed, but now the home page is not available.

    It actually displays posts, even if I choose as "Front page displays" a static page.

    Is there any know bug for this?

    Thanks for your help.

    Eugen

  2. demetris
    Member
    Posted 3 years ago #

    @Eugen

    I tried in 2 different setups with 3 different themes and I cannot reproduce. As far as I know, there is no bug report for this.

    Do you still have the problem?

  3. Eugen Oprea
    Member
    Posted 3 years ago #

    Thanks for you answer Demetris!

    I couldn't find any solution for this, so I had to reinstall WordPress. It works fine now on 3.0.2.

    Thank you!

    Eugen

  4. liquid7
    Member
    Posted 3 years ago #

    I have exactly the same problem. I'm using the Finnish 3.1beta.

  5. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    Hi guys, I know you've reverted back to 3.0.2, but it'd be great to narrow down the cause here.

    1) Does it work when using Twenty Ten? How about with Twenty Ten and no other plugins? (If so, what theme/plugins?)

    2) What are your settings on Settings > Reading exactly?

    3) Go to wp-admin/options.php. What are the values for page_for_posts, page_on_front, and show_on_front?

    Thanks,
    Nacin

  6. liquid7
    Member
    Posted 3 years ago #

    1) I'm using Thesis but it doesn't work with twenty ten either and I have disabled all plugins.
    2)All other settings are default but page for frontpage is selected. (The settings are same as with 3.0.2)
    3)page_for_posts = 0, page_on_front = 7, show_on_front = page

  7. Eugen Oprea
    Member
    Posted 3 years ago #

    Hi,

    I was using only Twenty Ten, but had these plugins installed:

    Automatic WordPress Backup
    Contact Form 7
    Contact Form 7 Modules: Hidden Fields

    I don't remember if I disabled them, as I tried one million of things to make it work.

    Hope this works.

    Eugen

  8. easilyamused
    Member
    Posted 3 years ago #

    Im using a child theme for Twenty Ten and I also got this same problem.

    Going to be downgrading back to WordPress 3.0.2

  9. loloontheair
    Member
    Posted 3 years ago #

    I have the same issue with 3.0.3

  10. I cannot reproduce this with 3.0.x or 3.1

    Disable all your plugins for starters and if you're NOT using 3.1, post in a new thread in another subforum :) This is for 3.1 folks only.

  11. loloontheair
    Member
    Posted 3 years ago #

  12. taeke
    Member
    Posted 3 years ago #

    Hi Nacin,

    I have a similar issue, noticed it before and running into it again.. Working with 3.1-beta2-17056
    I have page called 'Home' its ID is 59, i'd like to use a page template for home..

    1) Does it work when using Twenty Ten? plugins disabled..
    > Nope, doesn't work with 2010, not even after disabling all plugins.

    2) What are your settings on Settings > Reading exactly?
    > Front page displays: A static page (Home)
    Posts page: -select-

    3) Go to wp-admin/options.php. What are the values for page_for_posts, page_on_front, and show_on_front?

    > page_for_posts: 0
    page_on_front: 59
    show_on_front: page

  13. What's teh filename of the page template? Like is it home.php or ...?

  14. taeke
    Member
    Posted 3 years ago #

    it's called 01_homepage.php
    I've tried homepage.php and home.php but that didn't work.

    The wp3 custom menu doens't add a proper active class to home either, it would do that before..

  15. tictok
    Member
    Posted 3 years ago #

    Hi there -

    I think I'm having the same issue with WP 3.1-beta2

    However the lack of static front page issue only seems to occur when using a custom permalink such as /%category%/%postname%/

    Reading settings:
    A static page (select below)
    Front page: Homepage
    Posts page: Blogpage

    homepage template name 'myfrontpage' and file name 'myfrontpage.php'

    wp-admin/options.php
    page_for_posts 11
    page_on_front 128
    show_on_front page

    Going now to try the theme on a 3.0.3 wordpress install

    Cheers
    Stef

  16. demetris
    Member
    Posted 3 years ago #

    I have been following the thread since it started and I have not been able to reproduce yet (I even tried with %category% in the permalink structure, as tictok describes above.)

    @taeke, @tictok, if I may ask a question:

    What are the locations of your frontpage template files?

  17. tictok
    Member
    Posted 3 years ago #

    @demetris

    What are the locations of your frontpage template files?

    It's in the root of theme folder (same folder as index.php and other theme template files)

    Also discovered that is_home() or is_front_page() doesn't appear to detect or recognise the homepage either. (I tried a conditional check with my theme to load a different template page when on the home page... didn't work either).

    It's as if the post page is overriding / replacing the static homepage.

    I'll try a few more things this evening to double check (different templates, older no-beta version of wordpress etc) and report back

    cheers
    Stef

  18. demetris
    Member
    Posted 3 years ago #

    @tictok

    Thanks for the answer. I asked because the names of your homepage templates seemed uncommon to me.

    Regarding the conditional functions is_home(), is_front_page() etc.:

    They should work. If they don’t, it’s a bug. Do you by any chance use them directly, like this?

    if (is_home()) {
        # Do something.
    }

    In that case they are not supposed to work, because the WordPress query object is not yet set up at the time WordPress loads the theme files.

    There was an instructive thread about this some time ago at wp-testers:

    http://groups.google.com/group/wp-testers/t/3b311314110fe59d/7512d265de4f15c5

  19. liquid7
    Member
    Posted 3 years ago #

    I can confirm that when you use the default link structure static front page works, custom permalinks breaks it. It works with Twenty Ten and Thesis with all my plugins.

  20. taeke
    Member
    Posted 3 years ago #

    For me changing to default permalink structure fixes my menu issue, home is active now. But home uses index.php instead of the page HOME with custom page template..

  21. Eugen Oprea
    Member
    Posted 3 years ago #

    Just in case this helps, I was using the /%postname%/ custom permalink structure, too.

    Eugen

  22. Donal
    Member
    Posted 3 years ago #

    Any resolution to this issue? I'm having exactly the same problem with 3.1-RC1. If I revert to 3.03 the issue disappears and my static homepage works as expected.

    I've been doing some experimenting with my permalink structure and this is the behaviour I've noticed so far:

    If I use the default permalink structure (or any of the preset options), the problem disappears.

    If I set a custom permalink structure with the format /%postname/ or /%category%/%postname/ the problem reappears.

    If I set a custom permalink structure with the format /articles/%postname/ the problem disappears.

    Curiously, it seems that including a static element in the custom permalink solves the problem, whatever it is.

    I first noticed the problem in a theme I'm developing myself at the moment but I've checked with TwentyTen and the behaviour seems identical.

  23. Donal
    Member
    Posted 3 years ago #

    Edit - I've accidentally left out the ending % sign in some of the %category% and %postname% permalink elements above. That's just me making a typo here, not what I tried using as my actual permalink structure.

  24. Sergey Biryukov
    Trac Moderator
    Posted 3 years ago #

    Should be fixed by either of the patches in #16002.

  25. taeke
    Member
    Posted 3 years ago #

    I tried the patch but it totally messes up my two custom menu's.. The custom menu function seems broken after the patch..

  26. taeke
    Member
    Posted 3 years ago #

    Never mind, patch by greuben works like a charm!

  27. Ryan Boren
    WordPress Dev
    Posted 3 years ago #

    Thanks everyone for helping us track this down. This was a tricky one. Go to Dashboard -> Updates to auto upgrade to 3.1-RC1-17163, which contains a fix for this.

  28. thewisdomjournal
    Member
    Posted 3 years ago #

    Auto upgraded and it still doesn't work for me. I upgraded on Feb 28th and no new posts show up on my home page since then unless I'm logged in to WP admin.

  29. thewisdomjournal - Try the default theme for grins and giggles.

    If that fails, please make a NEW topic up in trouble shooting, as this is neither an alpha/beta bug NOR is it helpful to post in a 2 month old topic marked resolved :)

  30. arulpr
    Member
    Posted 3 years ago #

    i have the same issue what should I do ?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.