WordPress.org

Ready to get started?Download WordPress

Forums

Static home page disables blog page in 2.8.4 (3 posts)

  1. bdconley
    Member
    Posted 4 years ago #

    I have chosen for my front page to be static. I have chosen my blog page to show posts. The front page was based on a custom page and the blog page on a basic page. I set this up under the Reading Settings on the dashboard in the Front page section. THE PROBLEM: The front page is fine. The blog page only shows my title and nothing more. All other pages, based on the exact same page.php file, show everything else, navigation, pages, blogroll, etc. TEST: When I chose different pages to show the blog posts, such as About, Contact, etc., based on the same page.php file, they also showed only the title and nothing more, as well.

    Here is the code. Is something here conflicting with the Reading Settings core code when selecting a page other than the front page to be the blog page? This is the basic "Starkers" clean code for page.php:
    <<
    <?php get_header(); ?>

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?> <div class="post" id="post-<?php the_ID(); ?>"> <h2><?php the_title(); ?></h2> <?php the_content('<p class="serif">Read the rest of this page »</p>'); ?> <?php wp_link_pages(array('before' => '<p>Pages: ', 'after' => '</p>', 'next_or_number' => 'number')); ?> </div> <?php endwhile; endif; ?> <?php
    edit_post_link('Edit this entry.', '<p>', '</p>'); ?>

    <?php get_sidebar(); ?>

    <?php get_footer(); ?>
    >>

    Thanks.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Your Blog page should be using index.php as its template. Have you tried re-downloading the theme and replacing your index.php file? It could be damaged.

  3. bdconley
    Member
    Posted 4 years ago #

    Thanks for the suggestion. I am using a tutorial which doesn't seem to be working with 2.8.4. Although created this year, the tutorial was based on 2.7. I am writing the tutorial author as well to see if he can solve this.

    My frustration, is that the code I am using is a reset by Starkers for 2.8.4. It was a new upload so I don't understand why the conflict with the Reading Settings options. No matter what I choose as the blog template on the page settings, whether default or index, when I choose the blog page as the post page on Reading Settings, the blog page renders as blank. Clearly there is a conflict, I just don't know from what.

    There are no plug-ins activated. And even if there were, I am only considering those which have cleared as 2.8.4 compliant.

Topic Closed

This topic has been closed to new replies.

About this Topic