WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Static front page/place-holder blog page problem (14 posts)

  1. wperic
    Member
    Posted 2 years ago #

    Trying to set up a static home page and following the instructions at http://codex.wordpress.org/Creating_a_Static_Front_Page to create the "place-holder for showing the Posts":

    If you will not be using WordPress' blogging functionality, you can skip the second page; otherwise, title it "Blog" (or you could call it "News", "Articles", etc.). This page will be a place-holder for showing the Posts on your site.

    Do not use a custom Page template for this page! home.php or index.php will be used to generate this page.
    DO NOT add content to the Blog Page. Leave it blank. Any content here will be ignored -- only the Title is used.
    Publish the Page.

    When I create this page and select "Preview Changes," it shows up fine. But as soon as I publish the page and then try to go to it, I get the reply "The requested URL /dsescaleWP/blog/ was not found on this server". This is the url that WP creates when I create the blog page.

    What's going wrong?

  2. ChristiNi
    Member
    Posted 2 years ago #

    Hi wperic,

    Sorry you're having problem setting up a static page. There's something missing there in your URL, I do not see .com, .net., .org or something similar. So, let's take a step back.

    Did you create a new blank page named blog?

    Have you assigned that as your Posts page in your Dashboard Settings > Reading?

    You may want to check your Site URL as well and make sure it's set up correctly for your site. Look at the instructions here for how to view your site URL in your database, but only make changes if they are needed.

    http://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

    Hope this helps!

  3. wperic
    Member
    Posted 2 years ago #

    I do not see .com, .net., .org or something similar. So, let's take a step back.

    The site is on localhost. If I manually type in 'http://localhost/dscaleWP/blog' I get the same error message. However 'http://localhost/dsescaleWP' successfully opens the home page.
    Both WP Address and Site Address are correctly set for 'http://localhost/dsescaleWP'.

    Did you create a new blank page named blog?

    Yes

    Have you assigned that as your Posts page in your Dashboard Settings > Reading?

    Yes. The problem arises as soon as I "publish" the page and then try to preview it, so I don't think it has anything to do with the Reading settings.

  4. govpatel
    Member
    Posted 2 years ago #

    Have you got Mod_rewrite ON for permalinks to work try default setting and see the link works.

  5. wperic
    Member
    Posted 2 years ago #

    Where do I turn on Mod_rewrite?

  6. wperic
    Member
    Posted 2 years ago #

    Looks like mod_rewrite is on--"LoadModule rewrite_module modules/mod_rewrite.so" is uncommented in httpd.conf.
    And now I have an .htaccess file (755) in the root of my WP installation for this site.

    I've got my permalink set for "day and name"option. That would make me think the WP should assign this pattern, "http://localhost/dsescaleWP/2011/12/14/sample-post/". But when I create the new page it's assigning this pattern: "http://localhost/dsescaleWP/trial3."

    In fact neither of these URLs succeeds in finding the correct page.

  7. govpatel
    Member
    Posted 2 years ago #

    .htaccess file needs to be 644 and all files need to be 644 and folders 755

  8. wperic
    Member
    Posted 2 years ago #

    I've got everything from /var to .htaccess set at 777 (temporarily!). Still getting the same problem. As soon as I publish or update the page, apache tells me it's not there.

    Could it be something in the theme? I'm using a child theme from veryplaintxt.

  9. govpatel
    Member
    Posted 2 years ago #

    Switch to default theme to see if theme is the problem.

  10. wperic
    Member
    Posted 2 years ago #

    Good idea--but same problem with Twenty Eleven.

    Also I get the same problem when I try to use Permalinks with a different WP installation on the same computer.

    Is this the right location for .htaccess: DocumentRoot/dsescaleWP/.htaccess? WP seems to be writing the rule to this location OK.

    Is WP writing the correct rule?

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /dsescaleWP/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /dsescaleWP/index.php [L]
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /dsescaleWP/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /dsescaleWP/index.php [L]
    </IfModule>

  11. govpatel
    Member
    Posted 2 years ago #

    Have you got Mod_rewrite ON Is

  12. wperic
    Member
    Posted 2 years ago #

    ??

    Looks like mod_rewrite is on--"LoadModule rewrite_module modules/mod_rewrite.so" is uncommented in httpd.conf.

    Do I need more than that?

  13. wperic
    Member
    Posted 2 years ago #

    Can anyone help me on this? My WP is at Document Root/dsescaleWP.

    I've got "day and name" permalink setting chosen, yet WP assigns a different permalink without the day and name when I create a page. However neither the assigned permalink nor the "correct" on will open the page:

    The requested URL /dsescaleWP/test-page-2/ was not found on this server.

    I've got the .htaccess file and it's being written to:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /smashing/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /smashing/index.php [L]
    </IfModule>

    # END WordPress

    I believe mod_rewrite is on, since the line "LoadModule rewrite_module modules/mod_rewrite.so" is uncommented in httpd.conf.

    What else do I have to do to get permalinks to work right?

  14. wperic
    Member
    Posted 2 years ago #

    I think I finally figured it out--need to also allow a specific override in httpd.conf for the DocumentRoot directory.

Topic Closed

This topic has been closed to new replies.

About this Topic