WordPress.org

Ready to get started?Download WordPress

Forums

Static front page not working (5 posts)

  1. holney
    Member
    Posted 3 years ago #

    I'm using the Atahualpa theme on this site: http://start-model-engineering.co.uk/

    By default, the home page displays the most recent posts.

    Occasionally, I would like to use a static page for the home page.

    I've gone to Settings > Reading, clicked 'A static page' and selected a page from the 'Front Page' drop-down.

    However, this doesn't work - my home page still shows my latest posts.

    Any ideas?

    Many thanks in advance

  2. Samuel B
    moderator
    Posted 3 years ago #

    you will need to set a blog page, also
    http://codex.wordpress.org/Creating_a_Static_Front_Page

  3. holney
    Member
    Posted 3 years ago #

    Thanks Samuel

    Sorry I should have said - I selected a page for both the front page and the blog.

    It still has no effect.

  4. govpatel
    Member
    Posted 3 years ago #

    Did you create a Home page and add content and create blank page name it what you want and publish.

    In Settings Reading
    front page select Home or any page you want display as front page
    post page select the blank page.

  5. Samuel B
    moderator
    Posted 3 years ago #

    try switching to twenty ten theme temporarily to rule out theme error
    if that's not it - deactivate all your plugins and test
    re-activate one by one if site works as intended

Topic Closed

This topic has been closed to new replies.

About this Topic