WordPress.org

Ready to get started?Download WordPress

Forums

Starting over with 1.5 -- can't open style.css!! (5 posts)

  1. hscampbell
    Member
    Posted 9 years ago #

    Already, I guess I've forgotten almost everything I learned and I feel stupid.

    I lost my custom template for my blog, and so am getting ready to recreate it under 1.5.

    When I try to open either of the style.css files in Notepad to begin to edit, I am getting all sorts of extra characters. I thought a plain text editor was supposed to avoid this.

    What am I doing wrong?

    Thanks for any and all advice. I'm kind of sorry I upgraded, because although I'm sure it's my fault, it's left me in a bit of a mess. :(

    hsc

    P.S. does anyone know why a superscript TM (not using tags, but using the symbol) no longer works on my .php page? It still works on all my html pages, and USED to work on my .php page until my change. Again, thoughts appreciated.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What saved the css files ?
    Notepad on windows can throw problems too.

    I'd recommend either Notepad++
    http://notepad-plus.sourceforge.net/uk/about.php
    or Crimson
    http://www.crimsoneditor.com/
    or PSPad
    http://www.pspad.com/

    as solid alternatives.

  3. moshu
    Member
    Posted 9 years ago #

    Re: P.S. Encoding? Probably in your old html files it was the usual iso-8859-1 while in WP the default is utf-8. If you edit the WP files with an editor that doesn't have utf support, or you save the files with non-utf encoding - there will be all kind of strange characters.

  4. hscampbell
    Member
    Posted 9 years ago #

    Hi and thanks for your responses.

    Regarding the css files, I downloaded them from the WP site; this was my first attempt at opening them. Strangely, it opens nice and cleanly in Wordpad, but I know enough to know that I still shouldn't use it as a text editor. I'll check out the above sources.

    RE: the encoding, thanks; I'll see if I can work out what that means and whether I can fix it. The blog is only a small section of my website, but I use the_exerpt_reloaded to pull the lastest blog pulls onto my homepage -- thus, only the blog pages and the site homepage, http://www.dialogicconsulting.com, are php. Right now I've temporarily fixed it by using <sup> tags, but it screws up the areas that are underlined.

    Thanks, I learned most of this when I first set up the blog, but in the ensuing months it's slipped through the ever-enlarging fissures in my brain....

  5. hscampbell
    Member
    Posted 9 years ago #

    Thanks Podz; I downloaded Pspad and am now able to open the files without extra stuff. :)

Topic Closed

This topic has been closed to new replies.

About this Topic