WordPress.org

Ready to get started?Download WordPress

Forums

Starting a static home page (2 posts)

  1. hfdratch
    Member
    Posted 7 years ago #

    Yet another question showing my digital ignorance:

    I originally had WP installed on my host by them and put it as Sitename/blog1/ . I have asked here and gotten clear directions how to move the whole WP file system to Home.

    I decided, after trying it and making some errors (that I did rectify) that it was happy enough where it was and might be more logical to answer to the name "blog1". OK.

    Then I decided to make a Page in WP to use as the splash page at http://www.sitename.com/. It looks ok but placed itself as a Page within the blog.

    Then I studied this lengthy (and incredibly confusing) earlier thread at Creating_a_Static_Front_Page

    It begins by saying that on version 2.1 nothing on the page is correct or, maybe, some things are correct. That was worrisome but I copied the commands for adding header & footer and used the example for creating a splash page, named it home.html.

    I can't seem to get it in the right directory at the web host, PowWeb, or it is not correct. Here is what I ended up with in Smultron:

    <?php
    define('WP_USE_THEMES', false);
    require('./wordpress/wp-blog-header.php');
    get_header();

    ?>
    <div id="content" class="narrowcolumn">
    <h1 style="color:#000;">Welcome to my site</h1>
    <p>Welcome!
    (MESSAGE TEXT)
    Go
    straight to my blog.
    </p></div>

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    I left out the little message for brevity.
    Where am I going wrong? Or, where am I not going wrong?

    Thanks.
    Howard

  2. hfdratch
    Member
    Posted 7 years ago #

    I should add that I could also be having a problem with my getting my new home.html to replace the Home.html code at the host which says the site administrator needs to learn site administration (basically). I tried to move my file to it and then edited the Home.html page of theirs. No luck so I replaced the original code while I wait for advice.

    If it helps, my blog is at 7colorlagoon.com/blog1

Topic Closed

This topic has been closed to new replies.

About this Topic