WordPress.org

Ready to get started?Download WordPress

Forums

Seriously Simple Podcasting
[resolved] SSP, Jetpack, How to get G+ bar at the bottom of Podcast (7 posts)

  1. Teranoxis
    Member
    Posted 7 months ago #

    Hi,

    I Have the Lastest SSP (Seriously Simple Podcasting) plugin and Also Jetpack for WordPress (latest version).

    I've linked jetpack with my Google Plus Page for my blog.

    When I create an article I get my G+ follow box at the end of it, however, when I create a podcast, it is not displayed. I know it's because WordPress and Jetpack don't see SSP as an article or a page, but is there a way to make this work anyway?

    http://wordpress.org/plugins/seriously-simple-podcasting/

  2. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 7 months ago #

    I'm not sure how possible it will be to integrate with Jetpack as I haven't dived into that code properly yet. I'll have a look into it and see what would be possible there!

  3. Jeremy Herve
    Happiness Engineer
    Posted 7 months ago #

    We also discussed about this problem here. As I mentioned there, the single podcast template doesn't include the the_content() function, and Jetpack normally hooks the Google+ bar into the_content().

    Wouldn't it be possible to directly call the_content into the template, like so? This would allow third-party plugins to hook elements into the single podcast template.

  4. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 7 months ago #

    Hi Jeremy,

    Thanks for chiming in here - if using the_content() correctly will help this then I'll definitely switch it up. I'm fairly sure I had a good reason for not using at the beginning, but for the life if me I can't remember what it was. Thanks for the pull request - I'll review it and merge/edit it if I need to.

    Thanks,
    Hugh

  5. Jeremy Herve
    Happiness Engineer
    Posted 7 months ago #

    I haven't tested my change, so you might have a good reason not to call the_content() directly :) I just figured it would work after a quick look at your code but I'll let you do the test!

    Let me know if that helps!

  6. Teranoxis
    Member
    Posted 7 months ago #

    So any news about it?

    Could it work with the codes you were talking?

  7. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 7 months ago #

    I've had a look at the code and fixed this up in v1.7.5 that I will release this week. Once you have updated to that version then this should all be working properly for you.

Reply

You must log in to post.

About this Plugin

About this Topic