WordPress.org

Ready to get started?Download WordPress

Forums

ssl login impossible (9 posts)

  1. chavdarvideff
    Member
    Posted 8 years ago #

    Hi
    WordPress was working fine.
    Until I decided to go pulic and secure it.
    Running apache2.
    Configured apache for ssl - works with squirrelmail alright.
    Decided to switch to https and in wordpress admin - options set the WordPress and blog URI to begin with https: instead of http:
    Now I cannot login.
    I can browse the blogs ok but on the login page once I input my username and password I get redirected to login page againa and again.
    And now I cannot revert to the http: version.
    Where can I edit the URL again. And how can I push WordPress throgh ssl
    Regards
    Chavdar

  2. skippy
    Member
    Posted 8 years ago #

    If you have phpMyAdmin, you can browse the wp_options table for the following:
    option_name = siteurl
    option_name = home

    Edit these to use HTTP instead of HTTPS.

    There's no convenient way to run WordPress on both HTTP and HTTPS. If you're concerned about logins only, you could try my Secure Login plugin.

  3. chavdarvideff
    Member
    Posted 8 years ago #

    I don't use phpMyAdmin.
    Will this help
    http://blog.blackdown.de/2005/05/18/securing-wordpress-admin-access-with-ssl/
    There is a patch for ssl
    However to apply it I need to know the wordpress source directory. Is it where the site resides?

  4. skippy
    Member
    Posted 8 years ago #

    The WordPress source directory is the directory that holds your WP files.

    If you don't use phpMyAdmin, you can use whatever MySQL tool you prefer to modify the option_values associated with the option_names listed above.

  5. James
    Happiness Engineer
    Posted 8 years ago #

    Just apply the plugin that Skippy linked to above. It's, by far, easier to use.

  6. skippy
    Member
    Posted 8 years ago #

    Well, my plugin only deals with logging in, and not with wrapping SSL around an entire site. The HOWTO that chavdarvideff linked is a more robust (but far more complicated) means to run a single WordPress installation under both HTTP and HTTPS.

  7. James
    Happiness Engineer
    Posted 8 years ago #

    chavdarvideff, to fix your problem you will need either phpmyadmin or something else to access the database and correct the two values that skippy quoted in his first reply. If you can, I highly recommend installing phpmyadmin. It is an invaluable tool.

  8. chavdarvideff
    Member
    Posted 8 years ago #

    Ok fixed the URL in mysql.
    Now I am back to the non-ssl site (http).
    The patch in the howto didn't work but didn't ruin anything either.
    If I only have the site under HTTPS isn't it supposed to just run?
    This is what I thought: enable ssl for apache, edit virtual hosts and it is ok?

  9. chavdarvideff
    Member
    Posted 8 years ago #

    It's all there:
    http://codex.wordpress.org/Login_Trouble
    At the bottom.
    Thanks for all hints.

Topic Closed

This topic has been closed to new replies.

About this Topic