WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
SSL Host empty on subdomain install (3 posts)

  1. ururk
    Member
    Posted 1 year ago #

    I have a slightly different network setup - but it works:

    wp.example.com (primary site)
    something.example.com (network site)

    Normally WP creates subdomains such as something.wp.example.com, but it is possible to change this after the site is setup, which is what I am doing.

    When I set the site up, and save, the new site defaults are carried over, but the SSL Host field is empty. Is this because of how I have it setup?

    http://wordpress.org/extend/plugins/wordpress-https/

  2. ururk
    Member
    Posted 1 year ago #

    I just tested it out - even with the default domain (something.wp.example.com) the plugin is generating an empty SSL host value.

  3. ururk
    Member
    Posted 1 year ago #

    One other comment - it appears ssl_host is being created at some point, and the value is empty. When the install runs:

    foreach ( $this->getSettings() as $option => $value ) {
    				if ( is_multisite() ) {
    					if ( add_blog_option($blog_id, $option, $value) && isset($defaults[$option]) ) {
    						if ( $option == 'ssl_host' && strpos($value, 'https://') !== 0 ) {
    							$value = 'https://' . rtrim($defaults[$option], '/') . '/';
    						} else {
    							$value = $defaults[$option];
    						}
    						$this->setSetting($option, $value, $blog_id);
    					}
    				} else {
    					add_option($option, $value);
    				}
    			}

    It would appear if this setting is in the DB already (and it is somehow), it uses that and the computed value is empty.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.