WordPress.org

Ready to get started?Download WordPress

Forums

Challonge
[resolved] SSL error (11 posts)

  1. RSSS
    Member
    Posted 6 months ago #

    Hi,

    I've just installed this plugin and went to Settings to enter the API. After I generate it (at challonge.com) and paste in API Key field in plugin settings i get this notification:

    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed.

    I've tried disable SSL vertification, then it says that API key is valid, but I don't see any of the tournamets, o management menus...

    https://wordpress.org/plugins/challonge/

  2. RSSS
    Member
    Posted 6 months ago #

    Don't know how, but solved.

  3. zavaboy
    Member
    Plugin Author

    Posted 6 months ago #

    If you find out what you did differently that caused your issue, please let me know. Anyway, I'm happy you got it working. :)

  4. Sleeplessone22
    Member
    Posted 4 months ago #

    I'm having the same exact problem with same error code. any ideas on how to fix?

  5. zavaboy
    Member
    Plugin Author

    Posted 4 months ago #

    I'm afraid I can offer little help with SSL errors. You may have better luck with a Google search.

    If I come up with a possible solution, I'll be sure to post it here.

    Thanks for the feedback! :)

  6. greenlf
    Member
    Posted 4 months ago #

    open up your PHP.INI file and add the following line:

    curl.cainfo = "PATH_TO/cacert.pem"

    Get cacert.pem file from
    http://curl.haxx.se/docs/caextract.html
    and place it in the PATH_To.

    Example:

    I am running the WAMPDeveloper Stack on Windows from DevSide.net

    I added the following line at the bottom of my PHP.INI file
    curl.cainfo = "C:\WampDeveloper\Tools\curl\cacert.pem"

    Then I placed the cacert.pem downloaded above in:
    c:\wampdeveloper\tools\curl

    Works perfectly for most stacks, BUT NOT ALL, and resolves the issue for any plug-in looking for an updated CA.

    I would still like to see the developer properly include a cacerts.pem with the plug-in.

    Hope this helps,

    It works for me, but i don't know if i'm supose to see a new Menu after i've activated the plug-in or not?
    There is no screenshot of the interface we're supposed to see

  7. janik.otto
    Member
    Posted 4 months ago #

    Hello guys!

    I got a similar SSL-error after I moved from linux to a windows server:

    SSL certificate problem: unable to get local issuer certificate

    If I "disable SSL", I get the green string "verified", but then there's just the widget-text: "no api key".

    I already tried the tip above, but it did not work...

  8. zavaboy
    Member
    Plugin Author

    Posted 3 months ago #

    This should be fixed in the 1.1.3 update which I plan to release sometime this week.

    Thanks for the help, everyone! :)

  9. janik.otto
    Member
    Posted 3 months ago #

    Sounds great, but I currently have a tournament running - so may there be a quick fix until the update is released? :)

  10. zavaboy
    Member
    Plugin Author

    Posted 3 months ago #

    Download the cacert.pem file from greenlf's directions and place it in the Challonge plugin directory (wp-content/plugins/challonge/).

    Open the plugin editor (Plugins > Editor) and select Challonge, and edit class-challonge-api.php.

    Find this:

    if (!$this->verify_ssl) {
          // WARNING: this would prevent curl from detecting a 'man in the middle' attack
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYHOST, 0);
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYPEER, 0);
        }

    Add this just before that closing bracket:

    } else {
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYHOST, 2);
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYPEER, true);
          curl_setopt ($curl_handle, CURLOPT_CAINFO, plugin_dir_path( __FILE__ ) . 'cacert.pem');

    It should now look something like this:

    if (!$this->verify_ssl) {
          // WARNING: this would prevent curl from detecting a 'man in the middle' attack
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYHOST, 0);
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYPEER, 0);
        } else {
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYHOST, 2);
          curl_setopt ($curl_handle, CURLOPT_SSL_VERIFYPEER, true);
          curl_setopt ($curl_handle, CURLOPT_CAINFO, plugin_dir_path( __FILE__ ) . 'cacert.pem');
        }

    Save it and then go to the Challonge settings and enable SSL verification by unchecking the "Disable SSL verification" checkbox.

    This is essentially what the 1.1.3 update will do, so please let me know if this doesn't work for you!

    Thanks!

  11. zavaboy
    Member
    Plugin Author

    Posted 3 months ago #

    Version 1.1.3 was released with this fix.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.