WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
SSL configured on site causing Better WP Security to fail (11 posts)

  1. keithvaugh
    Member
    Posted 1 year ago #

    Hi there

    I have a site which is explicitly configured to use https (secured) connections and to use www for the domain in the .htaccess
    When I install and activate Better WP Security, it cycles and fails to allow the site to load.
    I am assuming that there is an issue with the .htaccess configuration
    Can anyone advise where I might be able to source a solution to this problem?

    http://wordpress.org/extend/plugins/better-wp-security/

  2. ernest_d
    Member
    Posted 1 year ago #

    Hi, I have same problem here.

    Two different sites, and one suddenly has fallen into cycle on SSL.

  3. ernest_d
    Member
    Posted 1 year ago #

    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

  4. shsu
    Member
    Posted 1 year ago #

    Same problem here too: only on HTTPS version of index.php for my site.

    Once I deactivated the plugin, everything https on the landing page worked.

    On my site, I did not activate any WP-Security options, just stock (so .htaccess shouldn't be a problem)

  5. ernest_d
    Member
    Posted 1 year ago #

    The problem was in wrong generated slef-signed SSL domain address,

    instead of domain.tdl I had http://www.domain.tdl

  6. shsu
    Member
    Posted 1 year ago #

    Hmm, mine is issued by a CA.

  7. ernest_d
    Member
    Posted 1 year ago #

    Check if you have or not have prefix www both on your site and generated certificate. I suppose if you want to have www. and no www. on site you might check if your certificate is a wildcard (*)

    I have chosen not to use www at all, and redirect my site to a a non www version.

  8. keithvaugh
    Member
    Posted 1 year ago #

    Hi Folks. Really would appricate it if someone could help me out here. I don't understant these .htaccess files, and therefore don't know what to try to sort out this cycling problem. Here is what I have

    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://www.magva.com/%{REQUEST_URI} [R,L]
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <files wp-config.php>
    order allow,deny
    deny from all
    </files>

    Options All -Indexes

  9. ernest_d
    Member
    Posted 1 year ago #

    To keithvaugh,
    have you enabled SSL on your hosting ?

    Your problem can come from this lines:

    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://www.magva.com/%{REQUEST_URI} [R,L]

    Try to remove/comment them and tell what happens.

  10. keithvaugh
    Member
    Posted 1 year ago #

    Thanks Ernest_d. That sorted the problem out for me. Not only that, the site is loading quicker now also

    Really appreciate the assistance.

  11. ernest_d
    Member
    Posted 1 year ago #

    You welcome.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.