WordPress.org

Ready to get started?Download WordPress

Forums

SSL Bug? Links convert to SSL (3 posts)

  1. bsuneja
    Member
    Posted 3 years ago #

    Noticed this since last few days (post 3.0 upgrade):
    - When I access the Dashboard using HTTPS, and go to the options page, WordPress changes the site address to HTTPS! I had the WP-Admin directory set to "Require SSL", and accessed the dashboard and admin pages using SSL.
    - When I create a new post, even if I manually type full path of image files or another page with "http://...", WordPress changes it to HTTPS://...
    - As a result, browsers that don't trust my certificate (e.g. iPhone and other Apple devices) don't show images until the certificate is manually trusted by the user.
    - When manually editing a post or any other link and changing links back to HTTP, the links are automatically changed back to HTTPS!

    Temporary workaround and validation:
    - Removed the "Require SSL" on wp-admin directory, accessed WP Dashboard using HTTP.
    - Site address on the options page now shows up with HTTP
    - Any links I manually change back to HTTP don't revert to HTTPS.

    Accessing the Dashboard again using HTTPS (without Require HTTPS on WP-Admin directory) results in links being changed back to HTTPS again!

    No SSL-related plug-ins.

  2. Mvied
    Member
    Posted 3 years ago #

    I would just like to add that a similar thing happens on the front-end. If you access your site via HTTPS, all links to other pages change to HTTPS. In my particular case, I only wanted a single page to be HTTPS, but WordPress insists on changing all the links on the page.

  3. Mvied
    Member
    Posted 3 years ago #

    Hey bsuneja,

    I've figured out a way to disable WordPress 3.0+ from changing links to HTTPS. I've added the option to my WordPress HTTPS plugin.

    Let me know if it works for you!

Topic Closed

This topic has been closed to new replies.

About this Topic