WordPress.org

Ready to get started?Download WordPress

Forums

ssh upgrade not working (8 posts)

  1. lilmike
    Member
    Posted 4 years ago #

    Hi,
    I am trying to use ssh to upgrade to wordpress 2.9.
    I get to the point where I have to enter my keys and connection info, and there I am stuck.
    I enter my key files, I enter my username and password, along with my host.
    I select ssh, and click proceed.
    It then gives me an error:
    Connection information is required
    I put in all of the information though.
    I am using mtgames.org for my host name, my username as my username, and the password and keys are all in the correct place, it seems.
    Any help is appreciated.
    -Michael.

  2. nsathees
    Member
    Posted 4 years ago #

    Try updating via ftp. (The forum is full of 2.9 problem. So I advice to wait another week or two before updating.

  3. lilmike
    Member
    Posted 4 years ago #

    Hi,
    I still can't get the ssh to work.
    I have heard that you should put the keys in a webserver-readable directory, such as /var/www.
    I also do not know what I am supposed to put in as the keys, if they were under /websites/yourdomain/public_html/sshkeys, should I put in /websites/yourdomain/public_html/sshkeys, or should I simply put in sshkeys, since it is already under the public_html? Or should I just put the keys under /var/www? or what.
    I still can't get it working.
    Also another question, when it says password, does that mean the password you supplied in ssh-keygen? or the password you use the connect to the server instead of keys.
    Thanks,
    -Michael.

  4. lilmike
    Member
    Posted 4 years ago #

    As a follow up, I can't update via ftp, as I don't have an ftp server on there yet, just sftp/ssh.
    Thanks.

  5. lilmike
    Member
    Posted 4 years ago #

    Well (*whacks self*), I didn't realize you were supposed to not put the id_rsa.pub and id_rsa part.
    Now, it seems to be (at least half way) working.
    I get to a page with the name:
    Upgrade WordPress ‹ Mtgames – insight, comments, and more! — WordPress
    It isn't much of a page, it has the following text on it (it looks like the menu and then the help link, but that is it):
    Upgrade WordPress ‹ Mtgames – insight, comments, and more! — WordPress

    Mtgames – insight, comments, and m… Visit Site

    Howdy,
    <my username> |
    Log Out

    New Post

    list of 14 items
    index

    Dashboard
    ?unfoldmenu=1
    edit

    Posts

    upload

    Media

    link-manager

    Links

    edit-pages

    Pages

    edit-comments

    Comments 2
    ?unfoldmenu=1
    themes

    Appearance

    plugins

    Plugins 1

    users

    Users

    tools

    Tools

    list of 4 items nesting level 1
    Tools
    Import
    Export
    Upgrade
    list end nesting level 1

    options-general

    Settings

    ?unfoldmenu=1
    list end

    Help
    Please note that the list end and list stuff is from my screen reader that I use because I am blind. It just signals the beginning and end of a list.
    Also please note that those links are links, just they don't come up from the paste and stuff.
    It seems like it's trying to load something, but it hasn't for the last few minutes.
    Does anyone know if wordpress usually loads a menu page then loads another page after that (for this is what I'm assuming it is doing).
    Thanks,
    -Michael.

  6. lilmike
    Member
    Posted 4 years ago #

    Another update (oh wow).
    Now it is changing the url displayed in the status bar, some times it just says internet 140% (meaning the magnification level), and some times it says something like http://<mydomain>/blog/wp-admin/wp-upload.php or do-core-upgrade.php, or others.
    -Michael.

  7. lilmike
    Member
    Posted 4 years ago #

    Ok, I let it go all night, and it still has nothing but the page down to help.
    Any help is appreciated.
    -Michael.

  8. Brent
    Member
    Posted 4 years ago #

    Hi Michael,

    A few things for you. Firstly, if you chown the files/folders in your wordpress root directory, you should fix the problem you're having.

    Try to give www-data permission in wordpress directory:

    cd /yourwordpress_dir/
    sudo chown -R www-data:www-data *

    As pointed out here: http://fredpalma.com/automatic-wordpress-upgrade-error-error-there-was-an-error-connecting-to-the-server-please-verify-the-settings-are-correct/

    Secondly, you said:

    I also do not know what I am supposed to put in as the keys, if they were under /websites/yourdomain/public_html/sshkeys

    You really shouldn't put a public/private key pair in your public_html directory. I'd remove them from there immediately.

    Hopefully using the chown fix above, you will be able to leave the keys in the default directory, as explained here: http://www.firesidemedia.net/dev/wordpress-install-upgrade-ssh/

    Best of luck!

    Brent

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.