WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
[resolved] SSH interference? (3 posts)

  1. doclalor
    Member
    Posted 1 year ago #

    I am not sure whether this is two issues run together in the logs, or one. Wordfence reported the following:

    Wordfence can't get the IP of clients and therefore can't operate. We received IP: 0. X-Forwarded-For was: REMOTE_ADDR was: Report the following on the Wordfence forums and they may be able to help. Headers that may contain the client IP: SSH_CLIENT => 75.xx.x.xxx 43172 22 SSH_CONNECTION => 75.xx.x.xxx 43172 67.xxx.xx.xxx 22
    It seems to me these might be two issues: one about unreadable IPs (not sure what that's about - maybe Cloudflare?), another about a nearby SSH connection? Anyway, I was SSH'd in to my server, so the SSH_CLIENT was me, and the 67.xxx.xx.xxx was in fact my server.

    Just reporting, as Wordfence requested. :-)

    Thanks for the rock-n-roll plugin!

    http://wordpress.org/extend/plugins/wordfence/

  2. Wordfence
    Member
    Plugin Author

    Posted 1 year ago #

    Those are just HTTP headers - not sure why they're being included. Upgrade to the newest version of WF and check the top of the "options" page where we've added a new parameter that lets you tell WF how to get client IP's. Play with this until it works.

    Regards,

    Mark.

  3. doclalor
    Member
    Posted 1 year ago #

    I saw the new feature: ...it seems to be working. Thanks!
    ~Brendan

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic