WordPress.org

Ready to get started?Download WordPress

Forums

Squares instead of end quotes? (5 posts)

  1. bi11i
    Member
    Posted 8 years ago #

    I recently upgraded both my PHP and mySQL to v5.0.4 and v4.1.11. I've got magic quotes turned on and I'm using the zlib output buffering.

    One of my bloggers has squares (a little ascii square) in place of his end-quotes and only at the end of a sentence, the first quotation is fine!

    Any ideas on what I'm done wrong here and how I can fix it?

    (also, I should mention that I have another wordpress blog of my own running on the same database and it appears to run just fine....)

  2. Kafkaesqui

    Posted 8 years ago #

    Several questions:

    1. Are posts composed in WordPress, or written elsewhere then pasted in?

    2. Is posting occuring through a third-party utility?

    3. Does character encoding under Options > Reading and what's displayed in the source (in the Content-Type meta tag) match up?

    4. What character encoding is in use?

  3. bi11i
    Member
    Posted 8 years ago #

    1. Composed in wordpress (to my knowledge)
    2. No
    3. my PHP.ini says:
    ; PHP's built-in default is text/html
    default_mimetype = "text/html"
    ;default_charset = "iso-8859-1"
    4. mySQL is set to UTF-8, so is WordPress - is my php.ini messed up?

    Thanks for your help...

  4. bi11i
    Member
    Posted 8 years ago #

    Hey, thanks for your first question. It never occurred to me that the guy was cutting/pasting from word. (which was the deal.)

    Thanks!

  5. ifelse
    Member
    Posted 8 years ago #

    Tell him to turn off Word's smart-quotes auto-formatting.
    Tools -> AutoCorrect options -> AutoFormat as you type -> Straight Quotes with Smart quotes.

Topic Closed

This topic has been closed to new replies.

About this Topic