WordPress.org

Ready to get started?Download WordPress

Forums

SQL Injection using Cast -- is WP secure? (4 posts)

  1. katami
    Member
    Posted 6 years ago #

    Hi All,

    Is WP 2.x+ secure from possible SQL injections using Cast? Have a WP blog and just got some bad news from a friend who's blogging system (not WP) was affected.

    Thanks
    Katami

  2. whooami
    Member
    Posted 6 years ago #

    Your question is too vague to answer. The differences between 2.1. and 2.6.1 alone make it nearly impossible to answer, in fact; as you see both those versions meet the version you specified in your question.

    There are insecure plugins, and unfortunately, there are insecure versions of WP.

    You indicate in your sidebar that you are using 2.5 -- I would recommend upgrading. Thats your first line of defense against any attacks, SQL injections or otherwise.

  3. katami
    Member
    Posted 6 years ago #

    Hi Whooami,

    Thanks. I have WP 2.5 installed and in the process of upgrading to 2.6.1. I couldn't find anything around here regarding sql injections using cast which is probably in itself a good thing.

    Thanks

  4. bplank
    Member
    Posted 6 years ago #

    2.5 was reponsible for the plague of SQL injection hackers. 2.6 does not have that vulnerability and 2.6.1 has the fix for the permalink issue in 2.6.

Topic Closed

This topic has been closed to new replies.

About this Topic