WordPress.org

Ready to get started?Download WordPress

Forums

WP-DBManager
[resolved] .sql file that's saved is man page for mysqldump command (12 posts)

  1. jmyweb
    Member
    Posted 5 months ago #

    WP-DBManager states I have the correct paths to mysql and mysqldump and exports the database successfully, but the .sql file that is copied is simply the manpage for the mysqldump command.

    Any idea why?

    Here's what's in the file...

    /usr/bin/mysqldump  Ver 8.22 Distrib 3.23.52, for suse-linux (i686)
    By Igor Romanenko, Monty, Jani & Sinisa
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL license
    
    Dumping definition and data mysql database or table
    Usage: /usr/bin/mysqldump [OPTIONS] database [tables]
    OR     /usr/bin/mysqldump [OPTIONS] --databases [OPTIONS] DB1 [DB2 DB3...]
    OR     /usr/bin/mysqldump [OPTIONS] --all-databases [OPTIONS]
    
    etc....

    https://wordpress.org/plugins/wp-dbmanager/

  2. Lester Chan
    Member
    Plugin Author

    Posted 5 months ago #

    Try this "My database is not backed up / My backup file is 0Kb" in http://wordpress.org/plugins/wp-dbmanager/faq/

  3. jmyweb
    Member
    Posted 5 months ago #

    I ran the command from SSH and it says: "No such file or directory"

    Permissions issue?

  4. Lester Chan
    Member
    Plugin Author

    Posted 5 months ago #

    Yea it seems you do not have permission to access mysqldump or the path to mysqldump is wrong?

  5. jmyweb
    Member
    Posted 5 months ago #

    I can run the command, but when I try to push the output to the directory, that's when i get the error.

    For example, this will get me the mysql prompt (e.g. mysql >), but when I try to push the output to a directory, that's when I get the error.

    This works:

    mysql -h sql5c40a.carrierzone.com -u ***** -p'******' db_name -A

    This doesn't:

    mysql -h sql5c40a.carrierzone.com -u ***** -p'******' db_name -A > /path/to/local/directory/filename.sql

  6. jmyweb
    Member
    Posted 5 months ago #

    I figured it out....seems my version of mysql doesn't like the following commands that are generated from WP-DBManager:

    --skip-lock-tables
    --default-character-set

    Also, the local path needs to be changed as well.

    How do I edit the 'mysql' command that WP-DBManager generates?

  7. Lester Chan
    Member
    Plugin Author

    Posted 5 months ago #

    The plugin doesn't use "default-character-set" but it uses "skip-lock-tables" and it is on Line 102 and Line 106 of https://github.com/lesterchan/wp-dbmanager/blob/master/wp-dbmanager.php#L102

    What version of mysql/mysqldump you using?

  8. jmyweb
    Member
    Posted 5 months ago #

    mysqldump: Ver 8.22 Distrib 3.23.55, for suse-linux (i686)
    mysql: Ver 11.18 Distrib 3.23.55, for suse-linux (i686)

    ...any way to edit the local path? It's not generated correctly for my server.

  9. jmyweb
    Member
    Posted 5 months ago #

    never mind about local path, saw it in the DB Options.

  10. Lester Chan
    Member
    Plugin Author

    Posted 5 months ago #

    Wow your mysqldump and mysql is way too old.

    Here is mine

    mysqldump Ver 10.13 Distrib 5.5.35, for Linux (x86_64)
    mysql Ver 14.14 Distrib 5.5.35, for Linux (x86_64) using readline 5.1

  11. jmyweb
    Member
    Posted 5 months ago #

    Yeah, not my choice...stuck working with Aplus.net hosting on this project and have to work with what they give me. ;)

    I think I got it figured out now. I just removed the two offending options from the mysql command and it works now.

    Thanks for helping me out - not every day that the author of a plugin responds so quickly and I appreciate that!

  12. Lester Chan
    Member
    Plugin Author

    Posted 5 months ago #

    No problem =) I didn't help much, you manage to solve it yourself =)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.