WordPress.org

Ready to get started?Download WordPress

Forums

Spun
[resolved] Spun theme and bbPres forums root (7 posts)

  1. stuudio
    Member
    Posted 1 year ago #

    For some reason I can not get the Spun theme to work with bbPres.
    Individual post look OK but if I go to my_site.com/forums/ I end up with this:

    http://www.oostuudio.ee/wp-content/uploads/2013/07/64-bbpres_spun_problem.png

  2. @mercime
    Volunteer Moderator
    Posted 1 year ago #

    @stuudio the issue per your screen capture is confirmed.

    You need to add a body class back to make it work for bbPress pages. See http://wp.me/p1I84P-67

  3. stuudio
    Member
    Posted 1 year ago #

    forum root page look OK now but all the rest of the pages disappeared.

    Patch usually shows the surrounding code too. It's unclear, what they mean by "at the bottom" of the file and

    Note:
    1. Need to remove list-styles in bbPress and BuddyPress components

  4. @mercime
    Volunteer Moderator
    Posted 1 year ago #

    forum root page look OK now but all the rest of the pages disappeared.

    Could you explain what you mean by "disappeared" and which pages "disappeared"? Tested the fix and all pages are showing up in default Spun theme.

    You add the code given at the very bottom (beneath all other code) of your theme's functions.php file.

    Need to remove list-styles

    List styles are the dots you see above or before the forums topics etc.

  5. stuudio
    Member
    Posted 1 year ago #

    if I add the code

    // Add Back page body class when bbPress and BuddyPress are active
    function mme_addback_page_body_class($classes){
        if( is_bbpress() || is_buddypress() )
                $classes[]="page";
            return $classes;
    
    }
    add_filter('body_class','mme_addback_page_body_class',20);

    to public_html/wp-content/themes/spun/functions.php
    I get the a blanc page and looking at the page source, i can see:

    <body
    Fatal error: Call to undefined function is_buddypress() in ...../public_html/wp-content/themes/spun/functions.php on line 338

    Same happens, if code is added to themes/spun/bbpress/bbpress-functions.php

    <body
    Fatal error: Call to undefined function is_buddypress() in ....../public_html/wp-content/themes/spun/bbpress/bbpress-functions.php on line 448

    Hopefully this makes sense :)

  6. @mercime
    Volunteer Moderator
    Posted 1 year ago #

    @stuudio sorry about that.
    Change line
    if( is_bbpress() || is_buddypress() )
    to
    if( is_bbpress() )

  7. stuudio
    Member
    Posted 1 year ago #

    Thank you. This works :)
    Case closed, problem resolved.

    Now I have to figure out, how to replace those almost unreadable fonts forums uses but this is a different "issue"

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic