WordPress.org

Ready to get started?Download WordPress

Forums

WP Splash Image
Splash image constantly appears on different pages (8 posts)

  1. jtfreelance
    Member
    Posted 1 year ago #

    I can't stop the splash video from appearing on every page, and it's irritating to me and my visitors.

    "Display always :" is left unchecked. It does not help.
    I have set the idle time to 29, 15, 30 and 300 minutes, this makes the video not show at all.

    I have tried clicking on the "Display always :" button, updating, then unchecking it, and that does not work either.

    Website: http://www.iamalifeartist.org

    http://wordpress.org/extend/plugins/wsi/

  2. tstruyf
    Member
    Posted 1 year ago #

    I have the same problem on multiple blogs. All blogs are running the latest version of wp-plash and WordPress 3.4.2 or 3.4.1

    In my case, the splash randomly displays. It's seems to be a 50/50 probability.

    Thx in advance!

  3. Renzomes
    Member
    Posted 1 year ago #

    This is happening for me too :( Also, my splash image isn't centred on the page?!

    Is it possible to have this image appear when a visitor first clicks onto the website and then doesn't appear again (even if the visitor clicks back onto the page that triggers the splash page in the first place) until the leave the website and then return again? This was what I was hoping this plugin would do. I loved it and am so disappointed that I've had problems :( I thought it was the answer to my web problems!

    Thank you Benjamin

  4. fireuponline
    Member
    Posted 1 year ago #

    I figured out a solution!

    Step 1: Check the "First load mode activated:" box.
    Step 2: Set your desired idle time (I chose 30 min). Make sure it's not 0.
    Step 3: Make sure the checkbox for "Display the splash image on each page..." is NOT checked (obviously).
    Step 4: Add the following statement to your header.php file, directly below <body>:

    <?php if( is_front_page() ) {
    do_action('wsi_first_load_mode');
    }?>

    This solution basically sets the plugin so that it requires the placement of it's code somewhere in the theme for it to work. So, that got me thinking...why not use and if-then statement that says: only run this code if you're on the homepage.

    It's working for me...let me know if I missed something, or you have any questions!

  5. drbotts
    Member
    Posted 1 year ago #

    ^

    Step 1: Check the "First load mode activated:" box.
    Step 2: Set your desired idle time (I chose 30 min). Make sure it's not 0.
    Step 3: Make sure the checkbox for "Display the splash image on each page..." is NOT checked (obviously).
    Step 4: Add the following statement to your header.php file, directly below <body>:

    <?php if( is_front_page() ) {
    do_action('wsi_first_load_mode');
    }?>

    I was about to give up on this plugin but this worked for me. +1 to this solution. Author needs to add more about this to the documentation.

  6. arczer
    Member
    Posted 1 year ago #

    This solution is not working in my case. I want to let visitor choose language version of my site but all the versions are on front page -
    mypage.com/en
    mypage.com/de
    mypage.com as default language

  7. fireuponline
    Member
    Posted 1 year ago #

    drbotts: I'm not sure the author really intended to build this in as a use, but I was hoping he would pick up on my code and perhaps build in this logic at some point. Glad it worked for you.

    arczer: I'm not sure what you mean by "all versions are on front page". Plus, I could be wrong, but I'm not sure this plugin is designed for interactive, clickable images.

    For what it's worth, if you would like the splash image to only show on a particular page:

    1. FTP into your site and navigate to '/plugins/wsi/wsi/front/splash/ and edit the file called content.inc.php

    2. Place the following code before the existing code:

    <?php
    if ( is_page('page-name') ) {
     ?>

    (obviously replace 'page-name' with the actual name of your page)

    ...and place this at the VERY end of the file:

    <?php } else { } ?>

    Hope this helps someone!

  8. micahgallant
    Member
    Posted 1 year ago #

    fireuponline: this works, great!

    This should totally be built in as an option, so you select the page you want it to show on!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic