WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] [closed] Spinning Icon, message sends, but no confirmation (32 posts)

  1. ACM
    Member
    Posted 1 year ago #

    i know this has been posted here before, but I've tried everything I could find that applies to this issue...

    I've moved my site to a different host. since moving, the contact form 7 forms DO send mail, but just get the spinning icon, and no 'your message was successfully sent' message (so user's keep clicking send over and over!).

    i've disabled all other plugins and still have the same issue.

    i do have several other sites which have been moved to the new provider (WP-Engine), all of which use CF7, and all the others seem to work..

    can anyone help?

    http://wordpress.org/extend/plugins/contact-form-7/

  2. ckhardy@gmail.com
    Member
    Posted 1 year ago #

    it's probably not loading the javascript for the Ajax response or the javascript is in conflict with another plugin. Did you upgrade to WordPress 3.5? I don't think contact form 7 has been updated for 3.5 yet. At least, it's not working on my site.

  3. kvwebmaster
    Member
    Posted 1 year ago #

    Having the same problem. Also upgraded to 3.5 last night.

  4. kvwebmaster
    Member
    Posted 1 year ago #

    Also, my emails don't get sent at all.

  5. ckhardy@gmail.com
    Member
    Posted 1 year ago #

    Actually, it works great in 3.5 for me. I had a snippet for Google analytics tracking and had forgotten to add my GA code to my header when I upgraded so it was failing on "__gaq not defined" error. After re-instituting my GA scripts, everything is good.

  6. ACM
    Member
    Posted 1 year ago #

    nope, still running 3.4.2..

    my first thought was a plug-in conflict, but have disabled everything with same problem.

  7. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried switching theme to the default one? Theme can cause conflict, too.

  8. kvwebmaster
    Member
    Posted 1 year ago #

    my mistake was rather dumb, I'm afraid.

    I had brought into my localhost for editing via duplicator...thus it wasn't actually on the real web server, which made sending mail difficult.

    Mine is working now...hope yours gets fixed soon!

  9. ACM
    Member
    Posted 1 year ago #

    mmm. have switched to twenty twelve theme, and disabled everything expect for Contact Form 7 itself.... same issue exists.

  10. Fabian
    Member
    Posted 1 year ago #

    I have the same problem here.

    The email is correctly sent but the icon is still spinning.

    I watched the http request (with firebug), I don't see any problem, I receive an ajax response from the server (success if all fields are filled in, error with the list of fields to fill in...). It should work but the contact form is not refreshed (with ajax I mean, the little box to display the errors or the confirmation that the email has been sent).

    Something is missing?

    I don't know since how long it is not working anymore, I just test it yesterday... I don't think there is extensions conflict, I didn't install any for a long time, but did some update...

    Any clues someone??

  11. Fabian
    Member
    Posted 1 year ago #

    Ok, I have finally found what the error was and correct it (actually this is a workaround).

    The http response was not in valid JSON format. Don't ask me why, but it included some html code before the real json data (i.e. before '{', something like

    <div style="display:none"><b></b><div>

    I am not sure where it is coming from (I got also this code when I'm editing the form in the admin). Whatever, here is a fix:
    Instead of json data, use 'text'. Then get ride of the unexpected html code (use substring and indexOf), then convert to json format (now it is ok). It works like a charm!

    Here is the code extract I added/modified (contact-form-7\includes\js\scripts.js, from line 22):

    data: { '_wpcf7_is_ajax_call': 1 },
    dataType: 'text',
    success: function(data) {
    	// remove invalide characters
    	data = data.substring(data.indexOf("{"));
    	data = $.parseJSON(data);
    

    Hope that little trick will help some of you. Look carefully the response content after the submit (e.g. use firebug for firefox), maybe you have the same problem, if not, this code won't help you at all...

  12. ACM
    Member
    Posted 1 year ago #

    hey carmano,

    i tried your code modification, still same issue..

    my understanding of AJAX is very limited, i don't suppose anyone would be able to take a look?

    my problem form is on http://www.acm.ac.uk/contact-acm/

  13. traffas
    Member
    Posted 1 year ago #

    I've actually solved this problem (CF7 v. 3.3.2 and WP 3.5 and earlier) by changing a couple of lines in the modules/special-mail-tags.php file.

    Change line 8 to
    function wpcf7_special_mail_tag( $output, $name, $html=false ) {

    And change line 82 to
    function wpcf7_special_mail_tag_for_raw_post( $output, $name, $html=false ) {

    Whatever is calling these functions isn't passing the html variable, so providing a default solves the problem of some forms sending but not displaying a success message.

  14. Fabian
    Member
    Posted 1 year ago #

    @Academy Of Contemporary Music
    I tried on your website, but you have deactivated ajax... Can't see the http response so.
    Maybe it is because of my modification, but I don't think so.

    But without ajax, it works, it just refreshed the entire page.

    I'm using WordPress 3.4.2 and CF7 3.3.2

    Anyway don't forget to backup your script.js first :) just in case!

  15. Fabian
    Member
    Posted 1 year ago #

    @Academy Of Contemporary Music

    here is the http request of you website:

    {<json valid code here}<!-- WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed! -->
    

    You have html code also, but at the end! Modify my code to delete the end, not the beginning. Or you can fix the cache plugin problem w-cache.

  16. araila
    Member
    Posted 1 year ago #

    I've been troubleshooting this problem myself - spinning icon, email sends, and then no confirmation on the page. As it turns out, I was using the old Analytics tracking code in the "Additional Settings" box of my contact forms (in order to do virtual URL tracking for my goals when a user submits the form).

    If you have a line of code in the "Additional Settings" box (when editing your CF7 form) beginning with "on_sent_ok" and it has "pageTracker" in it, you're probably using the old version of the tracking code.

    You can see more details here:
    http://contactform7.com/tracking-form-submissions-with-google-analytics/

  17. araila
    Member
    Posted 1 year ago #

    I'm using CF7 3.3.2 and WP 3.4.2

  18. ACM
    Member
    Posted 1 year ago #

    thanks carmano, looks like a cache plugin conflict indeed..

    interestingly, I no longer have WP-Super-Cache installed, but instead, the hosting company supply their own cache features, along with a WP plugin to control it. With that turned off, everything works again.

    thanks for helping point me in the right direction. i'll see if the host have any ideas on this conflict..

  19. helfenstein
    Member
    Posted 1 year ago #

    hi there! I've the same issue. Spinning icon, email received but no confirmation on the page or error messages (it seems an Ajax problem)

    I'm using WordPress 3.5 and Contact Form 3.3.2 (also, using WP-Mail-SMTP plugin)

    Try everything: switch to default theme, deactivate all plugins, remove my jquery code and try lot's of "miracle" fix I've found on web. Nothing works.

    So now I tried a "downgrade" to WP 3.4.2 and boom... it works fine (and even without WP-Mail-SMTP plugin as usual).

    I really like to use WP 3.5 but don't have a clue how to fix the Ajax problem.

  20. aj@isimplifyme.com
    Member
    Posted 1 year ago #

    I have this same problem and the above solutions have not worked for me

  21. helfenstein
    Member
    Posted 1 year ago #

    I've installed WP 3.5 in another directory and try with Contact Form 2.4.6. It works ok!

  22. dmhblogging
    Member
    Posted 1 year ago #

    I have the same issue as well - email fine, error messages working, but success message does not show. I have tested many things and the only change that corrects this is to take out the code for the GA tracking in the additional setting section. Is there any solution besides skip GA tracking or downgrading the version of either WP or the CF7? At this point I am just turning off the GA Goal Tracking.

  23. Tee888
    Member
    Posted 1 year ago #

    So I was sitting here doing everybody's recommendation. I'm getting the same issue. User would put information presses send, the spinning icon keeps spinning but message is actually sent successfully. No errors via firebug either.

    I have tried almost every ideas.
    - Downgrading to an older version of CF7
    - Disabled all plugins. Even deleted myPHP Database
    - Took of any Analytic codes, any cache plugins.

    This seemed to have WORKED~!
    So I tried what @Fabian was doing, and started to edit "contact-form-7\includes\js\scripts.js"

    As I decided to backup the original file renaming it to "scripts_old.js and dragging it to my desktop (using FileZilla FTP) Anyways I started to mod the original file via Dreamweaver. I tried refreshing my Page with the form, not realizing I don't have the "scripts.js" file on the actual server its still on my desktop. The form submitted successfully! So I tried several test runs and it all worked. The only difference is that The animation of the box with green border that says your submission is successful doesn't animate. Instead it seems the page refreshes.

    So my fix delete/backup scripts.js see if that helps!

  24. Tee888
    Member
    Posted 1 year ago #

    Also since this ruins the whole purpose of AJAX here's a temp fixed to the added url when screen is refreshed from submission. I got this from an older post 3 years ago

    Hi All,

    I had same problem. AJAX was not working in IE. I've tried IE6 and IE7. My html was valid... but there was just loading icon and nothing hapanned even if it was working in firefox withou issues.

    For me solution was to clear form action url which is in format:
    URI#unit_tag, for example /blog/#wpfc7_blabla

    It is enough to remove #wpfc7_blabla part. You can do it directly in plugin sources in includes/classes.php or you can add following code into functions.php of your theme to clear URL:

    function fix_wpcf7_ajax($url) {
    return '';
    }
    add_filter('wpcf7_form_action_url','fix_wpcf7_ajax');

    Unit tag (#wpfc7_blabla) is good for non ajax calls, because after page reload you will jump directly to form, but i can live without this but with working ajax with IE ;)

  25. inwd
    Member
    Posted 1 year ago #

    I turned off all of the plugins and still had a problem. Figured out it was the theme.
    I have found there is an issue with my theme and Contact Form 7 new 3.3.3.... went back to default theme and form works.

  26. Tee888
    Member
    Posted 1 year ago #

    I figured out what was happening, my "wp-blog-header.php" was somehow hacked or injected with a script that was causing my whole site to go Quirks Mode in IE, but looked normal on all other browser. But this script was also causing AJAX not to work correctly thus validating submissions incorrectly.

    After replacing the file, everything works and submissions now work properly.

  27. adamluz82
    Member
    Posted 12 months ago #

    I had the same issue. Mine was because I am on a Windows Server and had the captcha module installed. It was having issues deleting the files for the captcha and throwing a warning. Edit really-simple-captcha.php and anywhere you see unlink change it to @unlink. It should be around lines 190 & 215. There is actually a better fix to actually resolve the delete issue but this is a quick fix so messages can send again.

    To fully resolve this issue, see: http://wordpress.org/support/topic/plugin-really-simple-captcha-function-cleanup-unlink-permission-denied?replies=14

    If you do not fully resolve the issue, eventually your website will slow down drastically.

  28. V8cash
    Member
    Posted 11 months ago #

    Thanks Tee888!

    I clone my sites to start a new site (saves a lot of time) and I have been battling the "spinning icon, email send, but no confirmation".

    I deleted all plugins, removed captcha and tried everything suggested for this problem on the entire internet.

    Only deleting (I chose to rename) the scripts.js fixed the problem.

    I don't get the spinning icon anymore but I get my confirmation message and the email is sent and received.

    Thanks again!

    Bill

  29. WPDogger
    Member
    Posted 11 months ago #

    Why did someone mark this as Resolved? It has not yet been resolved.

    I have a problem where some people who submit the form do not experience any problems, while other just see the spinning icon after submission. They never get the messages. The data is being submitted, but some people are submitting it 10 times.

    No matter which browser I use, the forms work correctly for me, but not for some users, even when they try multiple browsers.

  30. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    This a 4 month old topic started by someone else. They marked it as resolved. Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.