WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Spinning Arrow with WP 3.3.1, Contact Form 7 & Really Simple CAPTCHA (31 posts)

  1. meganerd2012
    Member
    Posted 2 years ago #

    With WP 3.3.1, Contact Form 7 & Really Simple CAPTCHA, I get nothing but a spinning arrow. It actually does send out an email but I don't get the ajax confirmation on the screen.

    I changed themes and disabled all plugins. Finally when I disabled Really Simple CAPTCHA, it works.

    Any advice?

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    Where is your site?

  3. meganerd2012
    Member
    Posted 2 years ago #

    localhost right now. :)

  4. jstana
    Member
    Posted 2 years ago #

  5. grumo64
    Member
    Posted 2 years ago #

    Same for me on : http://dessinemoileco.com/qui-sommes-nous/
    Host : 1and1
    wp : 3.3.1
    contact form 7 : 3.1.1
    Really simple captcha : Version 1.5
    .htaccess : (for 1and1)
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Maybe it's a host issue because if I test the same contact form, and the same wordpress config on ovh host(french) it works !!

    It's a really recent bug because I don't change anything since fiew days and sudendly Spinning Arrow... :(

    Even if I delete Really simple captcha I got Spinning Arrow

    Please help

  6. grumo64
    Member
    Posted 2 years ago #

    For info if I tcheck my firebug I've got a strange reponse output :

    <style>#xzwi {position:absolute;overflow:auto;height:0;width:0;}</style><font id="xzwi"><a></a></font>{"mailSent":false,"into":"#wpcf7-f326-p46-o1","captcha":null,"message":"Erreur de validation. Veuillez v\u00e9rifier les champs et soumettre \u00e0 nouveau.","invalids":[{"into":"span.wpcf7-form-control-wrap.your-name","message":"Veuillez remplir le champ obligatoire."},{"into":"span.wpcf7-form-control-wrap.your-email","message":"Veuillez remplir le champ obligatoire."},{"into":"span.wpcf7-form-control-wrap.your-message","message":"Veuillez remplir le champ obligatoire."}]}

  7. MickeyRoush
    Member
    Posted 2 years ago #

    Try this:

    Open file:
    /wp-content/plugins/contact-form-7/wp-contact-form-7.php

    Edit line (around 50):

    Change this:

    define( 'WPCF7_LOAD_JS', true );

    To this:

    define( 'WPCF7_LOAD_JS', false );

  8. jstana
    Member
    Posted 2 years ago #

    @MickeyRoush

    Mod of script from TRUE to FALSE allows submission confirmation response. But disabling javascript check generates an unlink warning and a permissions denied statement across the top of rendered page.
    Not good.

  9. grumo64
    Member
    Posted 2 years ago #

    Not a good solution!

    I prefer understand what the problem is(host, hack...) and keep my core plugin clean for future update...
    Note that prev week all my forms works good !
    In my case if I tcheck my source code I find a
    <font id="xzwi"> juste before my closing body tag :(

  10. MickeyRoush
    Member
    Posted 2 years ago #

    jstana wrote:

    Mod of script from TRUE to FALSE allows submission confirmation response. But disabling javascript check generates an unlink warning and a permissions denied statement across the top of rendered page.
    Not good.

    I'm not experiencing any of that. Can you provide an image?

  11. MickeyRoush
    Member
    Posted 2 years ago #

    grumo64 wrote:

    Not a good solution!

    I prefer understand what the problem is(host, hack...) and keep my core plugin clean for future update...
    Note that prev week all my forms works good !
    In my case if I tcheck my source code I find a
    <font id="xzwi"> juste before my closing body tag :(

    May not be for your issue. I just thought it might help point you or someone else in the right direction.

    Good luck, may be someone else will help you.

  12. jstana
    Member
    Posted 2 years ago #

    @MickeyRoush

    The following errors were generated on the subsequent page after a successful submission using code, "define( 'WPCF7_LOAD_JS', false );"

    Sample of code warning, permissions denied

  13. grumo64
    Member
    Posted 2 years ago #

    Thanks evreybody,
    for me the probleme was on my host :(
    An old theme not secure...and not due to contact form7 or Really Simple captcha.
    Sorry for that,

    jstana,
    when I submit yor form, my firebug console return me a :

    <b>Warning</b>:  unlink(D:\inetpub\stana\blog/wp-content/uploads/wpcf7_captcha/1015595072.png) [<a href='function.unlink'>function.unlink</a>]: Permission denied in <b>D:\inetpub\stana\blog\wp-content\plugins\really-simple-captcha\really-simple-captcha.php</b> on line <b>190</b><br />
    <br />
    <b>Warning</b>:  unlink(D:\inetpub\stana\blog/wp-content/uploads/wpcf7_captcha/1015595072.txt) [<a href='function.unlink'>function.unlink</a>]: Permission denied in <b>D:\inetpub\stana\blog\wp-content\plugins\really-simple-captcha\really-simple-captcha.php</b> on line <b>190</b><br />

    juste before the output form, maybe it could help...

  14. grumo64
    Member
    Posted 2 years ago #

    Probably a chmod issue...

  15. jstana
    Member
    Posted 2 years ago #

    @grumo64,

    You caught my Contact Form 7 form javascript disabled, testing @MickeyRoush's suggestion. My linked sample image shows the same code errors.

    Normally, my trouble mirrors @meganerd2012's troubles exactly. So somehow it is a javascript issue calling the response after submission.

    Mail goes, CAPTCHA prevents BOTS, all good. Just no verification of send or fail, (the spinning arrow).

    And chmod is a non-issue on IIS.

    Thanks for the concern, hope you work out your issue.

  16. MickeyRoush
    Member
    Posted 2 years ago #

    grumo64 may have a point, as the author of the plugin just made some changes to try and make Really Simple Captcha more secure. I'm not sure all what he did but check to see if there's an .htaccess file in wp-content/uploads/wpcf7_captcha/. Since you're on an IIS (It Isn't Secure) machine, I'm not really sure what to tell you.

    :)

  17. christian70
    Member
    Posted 2 years ago #

    i got the same issue (arrows spinning endlessly) with really simple captcha 1.5 and contactform7 3.1.1 installed. i just uninstalled the current version and installed the old 1.4 one instead and everything is working fine now.

  18. jstana
    Member
    Posted 2 years ago #

    @ christian70
    Could not find the older ver., so got a different plug-in from Mike Challis with all the trimmings.
    Never looked back.

  19. meganerd2012
    Member
    Posted 2 years ago #

    Open file:
    /wp-content/plugins/contact-form-7/wp-contact-form-7.php

    Edit line (around 50):

    Thank you. That worked for me but disabled the javascript and was hoping to look for a fix.

    I installed the newest WordPress, newest version of Contact Form 7 and newest version of Really Simple Plugin yesterday. Same thing.

    Finally, I just did what christian70 did and installed 1.4. Works fine now.

  20. burtatbase
    Member
    Posted 2 years ago #

    Just thought I'd share something that appears to work for me, though I'm not sure yet if it has any negative implications for the use of the plugin.

    If you open really-simple-captcha.php and head to line 190 you'll see:

    foreach ( $suffixes as $suffix ) {
    			$filename = sanitize_file_name( $prefix . $suffix );
    			$file = trailingslashit( $this->tmp_dir ) . $filename;
    			if ( is_file( $file ) )
    				unlink( $file );
    		}

    Line 190 is the line indicated in the error message you may either get back in your POST response, or displayed on the page if JavaScript is turned off.

    I decided that this functionality can't be that important so I changed this section to:

    foreach ( $suffixes as $suffix ) {
    			$filename = sanitize_file_name( $prefix . $suffix );
    			$file = trailingslashit( $this->tmp_dir ) . $filename;
    			if ( is_file( $file ) ){
    				//Commented this out because it breaks things and makes me sad.
    				//unlink( $file );
    			}
    		}

    This seems to do the trick for me, really annoying issue, hopefully it gets sorted at some point soon.

  21. burtatbase
    Member
    Posted 2 years ago #

    A while later it's become evident that the above actually has a nasty habit of stopping emails being sent, so maybe it isn't a good idea after all!

  22. phew72
    Member
    Posted 2 years ago #

    Thank you @christian70

    Replacing v1.5 with v1.4 worked. That can be found at: http://plugins.svn.wordpress.org/really-simple-captcha/tags/1.4/
    (just download and replace the really-simple-captcha.php file only)

    Strangely this problem is only with my local server (XAMPP). The live version of 1.5 works fine.

  23. evancamilleri
    Member
    Posted 1 year ago #

    Same with me, changing to [1.4] works!

    ( Just replace the file really-simple-captcha.php from website http://plugins.svn.wordpress.org/really-simple-captcha/tags/1.4/ )

    My problematic 1.5 installation is on an IIS machine... so maybe that's the issue with 1.5?

    Evan
    http://www.holistic.com.mt
    http://www.evancamilleri.com

  24. McShaman
    Member
    Posted 1 year ago #

    OMG I posted about a similar problem assuming it was a Contact Form 7 problem... But disabling Really Simple CAPTCHA fixes everything.

    Does Takayuki Miyoshi know about this issue?

  25. McShaman
    Member
    Posted 1 year ago #

    Just re-enabled Really Simple CAPTCHA 1.5 and its working now... Odd

  26. WebProLive
    Member
    Posted 1 year ago #

    I had the same problem with my Locksmith website, I just had to remove the CAPTCHA all together. I wasn't getting the emails that I was testing then the next day I would try and it worked again.

    Could this be a hosting issue?

    Thanks.

  27. Ashraf Jaddo
    Member
    Posted 1 year ago #

    same problem here.. hosting with IIS (http://stats.allium.arvixe.com/phpinfo.php)
    and Plugin 1.5 does not work (spinning arrow for ever but I get the email).

    I downloaded 1.4 and replaced only really-simple-captcha.php makes it work..

    Does Takayuki Miyoshi knows about this issue?

  28. WebTechLive
    Member
    Posted 1 year ago #

    Seem's to be a hosting issue with the plugin. I have a Driving Lessons website on Register365 and I added CAPTCHA to the contact form with no joy.

    I have gotten on to my hosting and still awaiting a reply.

  29. Seamoose37
    Member
    Posted 1 year ago #

    Caljos's solution at the end of this thread worked for me. No idea if it is a bad idea or not but it totally worked ... http://wordpress.org/support/topic/plugin-really-simple-captcha-submit-appears-to-be-timing-out-but-its-really-working

  30. WebProLive
    Member
    Posted 1 year ago #

    I re-installed CAPTCHA within another website WP website I developed Carpet Cleaning Dublin and it now seems to be working fine on Reg365 hosting. So it must have been a server issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic