WordPress.org

Ready to get started?Download WordPress

Forums

Spelling Checker plugin for WordPress (58 posts)

  1. ColdForged
    Member
    Posted 9 years ago #

    Hello,
    Saw a need and decided I wanted to fill it. I've created a spelling checker plugin that integrates into the post/edit page, no changes to the existing code base. Please give it a shot and see what you think. Take a look here:
    Spelling Checker plugin for WordPress
    Thanks!

  2. RummandDan
    Member
    Posted 9 years ago #

    The plugin really rox :) This is on of the most usefull "small" plugins i have tried out.

  3. ColdForged
    Member
    Posted 9 years ago #

    Thanks, glad you found it useful.

  4. Anonymous
    Unregistered
    Posted 9 years ago #

    Silly question, but what does it mean to untar the file...?

  5. iraq
    Member
    Posted 9 years ago #

    LOL
    That is great

  6. Jennifer Ledbetter Clay
    Member
    Posted 9 years ago #

    Yay! I like the plug in. If *I* can get this to work, anyone can :)

  7. ColdForged
    Member
    Posted 9 years ago #

    Please note that I've released a new version that includes the ability to allow your readers to check their spelling before submitting comments. Hope it helps someone!

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    no aspell here :(
    '--with-pspell' only...

  9. Joshua Sigar
    Member
    Posted 9 years ago #

    there's spell checker extension for firefox, forgot the name

  10. ColdForged
    Member
    Posted 9 years ago #

    Note that the lastest version has been released. This version includes the ability to add words to the dictionary. Hope it helps someone!

  11. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I have no idea what I was on the other day, or why I made it not work, but it works perfectly now with 'pspell' on my server.
    Thank you for this plugin :)

  12. ColdForged
    Member
    Posted 9 years ago #

    Awesome podz! You're the first I've heard running it that way.

  13. RummandDan
    Member
    Posted 9 years ago #

    ColdForged, I get an JavaScript error when writing a new post (not edit).

  14. RummandDan
    Member
    Posted 9 years ago #

    erhm thought i pasted the javascript error, damn me. :D
    Error: savebutton has no properties
    Source File: http://rummanddan.dk/wp-admin/post.php Line: 170
    I corrected the error in my case with this small hack:

    < script language="JavaScript" type="text/javascript" >
    var savebutton = document.getElementById("save");
    if (!savebutton)
    {
    savebutton = document.getElementById('saveasdraft');
    }
    var submitp = savebutton.parentNode;
    var substitution2 = document.getElementById("spellingdiv");
    submitp.insertBefore(substitution2, savebutton);
    < /script >

  15. west4me
    Member
    Posted 9 years ago #

    Podz:
    I also have pspell on my hosted server. Could you tell me how you got this to work, i.e., what you had to change? Thanks.

  16. Mark (podz)
    Support Maven
    Posted 9 years ago #

    west4me - nothing ....
    I did a infophp. ctrl-f just shows pspell so I just uploaded and tried it..I've just checked my files and I cant see 'pspell' anywhere, so quite how it's working I don't know !
    From my infophp:
    pspell
    PSpell Support enabled

  17. ColdForged
    Member
    Posted 9 years ago #

    Bear in mind, podz, that aspell is an actual executable on the server, not a PHP service of any kind. If you have shell access, just do an "aspell" and see what comes up :).

  18. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Ahhhhhhhhhhhhhhhhhhhhhhh !
    I hate doing this shell stuff as my pw's are so long and complex, but doing that does indeed produce a lot of info.
    I really am clueless at times :)

  19. west4me
    Member
    Posted 9 years ago #

    Too bad I don't have shell access. I installed it and tried checking the spelling. All worked fine but nothing appears in the spell check area. I believe the script is working perfect but I just don't have aspell on the server.

  20. eragle
    Member
    Posted 9 years ago #

    Anybody else install this only to have it stop working several days later? It was working just fine....

  21. ColdForged
    Member
    Posted 9 years ago #

    Define "stop working". In the absence of any updates to your WordPress installation the only other thing that might chnage would be underlying PHP or MySQL versions.

  22. jvswan
    Member
    Posted 9 years ago #

    So, west4me mentioned that the spell check are is empty. That is what is going on with me. Is that an "aspell" thing? If all seems to work but the spelling info is empty, is my server missing the aspell or pspell?

  23. ColdForged
    Member
    Posted 9 years ago #

    Check the FAQ. Two possibilities are an aspell path issue or a failure to create/write to the personal dictionary due to a path or permissions problem. Hope this helps.

  24. jvswan
    Member
    Posted 9 years ago #

    Thanks for telling me about the FAQ. I didn't know it was there. I got the path from the technical support folks (/usr/bin/aspell) but it still is showing a blank in the spell checker. What are the permissions that I need to use and where do I find the personal dictionary? I couldn't find this info in the FAQ.

    I'm using PHP version 4.3.10.

  25. ColdForged
    Member
    Posted 9 years ago #

    Your personal dictionary should be located somewhere that the web server has permission to write to. I can't tell you where this is for your installation... perhaps you can create a directory under your home directory for it to use and chmod it to allow everyone write permission, then change the path in the spellConfig.php file to point there.

    Hope this helps.

  26. jvswan
    Member
    Posted 9 years ago #

    Hmm. I just changed the permission on the spell directory to read and write and I get a curious error. It says "usr/share/aspell/en_US.dat: The required field "name" is missing." It seems to be trying to work, now.

    Any thoughts?

  27. ColdForged
    Member
    Posted 9 years ago #

    You can try a different language setting in that same config file. Try simply "en" or maybe "english". That also depends on your aspell installation.

  28. jvswan
    Member
    Posted 9 years ago #

    I sure appreciate your help. I'm still getting an error with each attempt at a language def. The complete error (the same as before) reads: Error executing '/usr/bin/aspell -a --lang=en
    --personal-/home/goswans/public_html/wp-content/plugins/spell/aspell
    </tmp/aspell_data_Go6GY2 2>&1'
    /usr/share/aspell/en_US.dat: The required field "name" is missing.

    Does this mean anything to you, ColdForged?

  29. jvswan
    Member
    Posted 9 years ago #

    BTW, I did find the personal dictionary and I changed the permission to read and write.

  30. ColdForged
    Member
    Posted 9 years ago #

    I forgot to mention removing the personal dictionary file between attempts at changing the language, though that may or may not help. I'm curious why it still complains about en_US.dat when you're specifying an "en" language.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.