WordPress.org

Ready to get started?Download WordPress

Forums

Spellcheck throws error - Other alternatives? (6 posts)

  1. tinwatchman
    Member
    Posted 5 years ago #

    So a site I'm currently working on keeping throwing this error whenever someone clicks on the Spellcheck button in the Rich Text editor:

    `Error response:
    <b>Warning</b>: fsockopen() [function.fsockopen]: unable to connect to ssl://www.google.com:443 (Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?) in <b>D:\Web Sites\dcgNew\blogs\harris\wp-includes\js\tinymce\plugins\spellchecker\classes\GoogleSpell.php</b> on line <b>85</b>
    Could not open SSL connection to google.{"id":null,"result":[],"error":null}`

    Before anyone points it out, yes, I did find this already in the forums. Without going into too much detail, though, installing new modules up on the site's server is going to be a massive pain-in-the-neck for me. So I'm wondering if anyone else knows a shortcut - is there any way to get WordPress to contact the Google server in a different way? Or get it to use a different spellchecking library?

    Thanks.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    You can't make it use Google if you are not willing to install the SSL libs or CURL on the box. Really, it's not that hard. Like one command on most Linux installations.

    If you have pspell or the command line aspell installed on the machine, you can have it try that. Examine the wp-includes\js\tinymce\plugins\spellchecker\config.php file to see how to configure that.

  3. hphovercraft
    Member
    Posted 5 years ago #

    I know this may be of little help, but I always use the built-in spell checker in Firefox. Works great.

  4. tinwatchman
    Member
    Posted 5 years ago #

    Really, it's not that hard. Like one command on most Linux installations.

    Ah, but unfortunately, we're not talking about Linux here. We're talking about IIS. That's one among the issues it looks like I'm going to have to work out.

    I know this may be of little help, but I always use the built-in spell checker in Firefox. Works great.

    Point taken, but if the guy I'm making the site for sees a button, he's going to want to use it. Otherwise, he isn't going to want it there at all, which may be even more of a pain in the neck.

    ... Okay, so I'm going to presume at this point that there isn't any easy way around this. Oh, well. I'd better start arranging access to the server... Thanks for your help, everyone. Appreciate it.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Argh...

    Switch to a Linux hosting solution. Nobody seriously uses IIS/Windows for hosting. Run Apache on Linux instead.

    And the latest Windows PHP binaries support SSL connections just fine. Download the most recent PHP 5 for Windows, install that.

  6. akaoni
    Member
    Posted 4 years ago #

    For the other nobodies out there, like me, who seriously use IIS/Windows:

    You need to enable the CURL library in PHP.

    1. Uncomment (or add) the following line to the "Dynamic Extensions" section of your php.ini file:
      extension=php_curl.dll
    2. Make sure the following files can be found from your PATH system variable (I copy them to C:\windows\system32\):
      libeay32.dll
      ssleay32.dll

    Hope that helps. ; )

Topic Closed

This topic has been closed to new replies.

About this Topic