WordPress.org

Ready to get started?Download WordPress

Forums

Spell Checker Not Working in WP2.1 (20 posts)

  1. jdquel
    Member
    Posted 7 years ago #

    I just installed WP 2.1 and the long awaited spell checker is refusing to work. Instead when I write something and go to spell check it, I get this...

    "could not execute AJAX call, server didn't return valid a XML"

    Worse yet, Firefox's inline spell checker only works in code view and not in visual. Can anybody help me with this? Even if I can't get the WP spell checker to work, I would at least like to get it to recognize the Firefox one.

  2. kjarrett
    Member
    Posted 7 years ago #

    Hmmm. I was getting the same error, but now I'm not ... however the SC is inoperative ... it runs and finds 'no errors' in this text:

    fencs fasfdsafa sdfg adsf z zxdf asdfasd

    Odd. Is the SC working for others?

    -kj-

  3. supor1t
    Member
    Posted 7 years ago #

    The spell check built into 2.1 isn't working for me either.

    Also FireFox no longer automatically checks the post field for me.

    I'm back to my google toolbar for spell checking.

  4. vacortes
    Member
    Posted 7 years ago #

    Today I just installed WordPress 2.1 and unfortunately I realized tha the spellchecker just doesn´t work. I got just the messege "No misspellings found" even though there are several misspelled words.

  5. jennmiller
    Member
    Posted 7 years ago #

    Same result here. Is there a way to turn off the spell checker so that Firefox's spell checker can run?

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Re: Your AJAX problems: You might have adblocking software or something else in your browser interfering. I suggest disabling any such software, or adding your site to its whitelist, if it has one.

    Re: Enabling the inline Firefox spell checker again: Read this post on my blog. It has a plugin that will do just that.
    http://ottodestruct.com/blog/2007/01/26/enable-firefox-spell-checking-in-wordpress-21/

  7. tamar
    Member
    Posted 7 years ago #

    I'm vouching for Otto's plugin... it is great :)

  8. samanathon
    Member
    Posted 7 years ago #

    Just wanted to let you all know that it doesn't work for me in the WYSIWYG editor either. And Firefox doesn't see the errors either - but does in Code view ....

  9. Webmgr
    Member
    Posted 7 years ago #

    I am having the same AJAX error on my install, regardless of browser. I already use Firefox, but it is not a valid solution to "force" it on all of my users, so I'd love to hear some suggestions on actually resolving the AJAX error.

    It's an IIS server on Windows Server 2003... if any other information is needed, please let me know, and I will provide what I can.

    Regards,
    Aaron Hall

  10. WPChina
    Member
    Posted 7 years ago #

    Yes, My spellcheck was working great in 2.1 in Forefox for a couple days after I upgraded to 2.1, but all of a sudden it failed to work. I did not do anything to Firefox... any ideas?

  11. WPChina
    Member
    Posted 7 years ago #

    Ok, I installed Otto42's plugin and then restarted my computer, but I still can't get Firefox to check spelling... anybody else have any fix or other ideas?

  12. Pisanojm
    Member
    Posted 7 years ago #

    I too am experiencing this. The spell check worked fine and now I am getting the AJAX error. I suspect it may be a plugin, so I am going to begin disabling them one by one. I'll let all know what happens, if anything.

    Joe Pisano
    http://www.mustech.net

  13. jasondunn
    Member
    Posted 7 years ago #

    I didn't have the spell check working in 2.1 and now it's still not working under 2.1.1. I posted a support message in these forums weeks ago, not a single response. What's killing me about this is that I'm not getting any sort of error, so I don't even know where to BEGIN to debug the problem. I click on the spell check button and it tells me there are no misspellings - even when I have words such as "dogg" in my post.

    I know WordPress is free and all that, but I haven't seen or heard an official peep on how completely broken spell check is...does anyone care?

  14. WPChina
    Member
    Posted 7 years ago #

    I did a work-around. I installed the spellcheck plugin for Firefox and now that handles things for me at the browser level. However, when I add the <!--more--> tag to a post when using the WYSIWYG, the Firefox spellcheck turns off... so, I too still have not found a 100% great solution...

  15. xinfo
    Member
    Posted 7 years ago #

    i belive there need curl installed in your server where blog is hosted

  16. antonyh
    Member
    Posted 7 years ago #

    Anyone managed to get spell checking to work in version 2.1.1/2.1.2 yet? Does anyone have it working at all? I get the same response as jasondunn, "no mistakes"...

  17. greentick
    Member
    Posted 7 years ago #

    My host asked for this:

    "Hmm... could you paste the requirements of that AJAX Spell Checker? Because most likely the server has everything, just need to change the settings a bit."

    So, he thinks it's server issues and not wordpress.. I think this is an old topic anyway hope someone can help :)

  18. mrslother
    Member
    Posted 7 years ago #

    I finally resolved this problem on my system running Windows Server 2003 with IIS. I installed WordPress v2.2 and ran into the same AJAX error. It ends up that the spell checker config.php file was configured to only use Google's spell check web service. However it requires the use of SSL which my PHP was not configured for.

    Long story short I modified the config.php file and had to hack the TinyPspellshell.class.php file but was able to get everything working (although I had to install a copy of aspell.exe).

    I posted details on how I fixed this:
    http://www.roth.net/blog/index.php/2007/06/25/wordpress-v22-spell-checking-problem/

    I hope this helps someone.
    Cheers!

  19. silverfox47
    Member
    Posted 6 years ago #

    I am running 2.3.1 and I saw the same error - I fixed it by modifying the config.php in
    /wp-includes/js/tinymce/plugins/spellchecker

    as follows:

    Removing the // comments from this line
    require_once("classes/TinyPspellShell.class.php");

    and adding comments to this line
    // require_once("classes/TinyGoogleSpell.class.php");

  20. spllogics
    Member
    Posted 6 years ago #

    Here is a fix.
    Just download the file and replace it.
    http://df.spllogics.com/wordpress-spellcheck-fix

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.