WordPress.org

Ready to get started?Download WordPress

Forums

Spell Checker for WP 2.0 (13 posts)

  1. RaymondDay
    Member
    Posted 8 years ago #

    I guess there is not Spell Checker for Word Press 2.0 yet right? Is some one working on one? I miss that in the 1.5 WP I had.

    Is there some place to get a plugin for it all ready?

    -Raymond Day

  2. Truth
    Member
    Posted 8 years ago #

    there is plugins for spell checkers though

    http://www.coldforged.org/spelling-checker-plugin-for-wordpress/

    working in wp 2.0 for me other than the fact that I cant add words to the dictionary =x

    it's mentioned by the plugina author that it doesn't play well with wp2.0 but so far, I think it's great =p

  3. RaymondDay
    Member
    Posted 8 years ago #

    I went to that link and downloaded the zip and unzipped it all in a folder and moved the folder to /var/www/html/wordpress/wp-content/plugins with WinSCP then in the folder did Properties of the 5 php files to 755 and went to my Options page and just resaved it then plugins and Activated it. I now see a "Check Spelling" in WordPress. But when I click it on at the buttum it will say "error on page" and nothing comes up.

    I running this on Fedora core 4 and getting to it with Windows Internet Exploer.

    -Raymond Day

  4. Ryan Duff
    Member
    Posted 8 years ago #

    you changed the permissions on the files, but what about the owner and group? If the ownership is not correct, the webserver might not be able to read a file or something along those lines.

  5. abbaanthony
    Member
    Posted 8 years ago #

    BTW, it does work with 2.0 but you have to turn off the WYSIWYG editor and use the editor that 1.5 came with. Someday he may upgrade it to 2.0 but for now I am happy using it with the old editor.

  6. whitebalcony
    Member
    Posted 8 years ago #

    duh? how do i turn off the wysiwig editor?

  7. whitebalcony
    Member
    Posted 8 years ago #


  8. Chip Bennett
    Theme Review Admin
    Posted 8 years ago #

    RE: how to turn off the WYSIWIG editor -

    Either disable it globally (Options/Writing) or disable it from your profile (Users/Your Profile)

  9. RaymondDay
    Member
    Posted 8 years ago #

    I got it working. I had to start over installing it. What every I did my wordpress would come up blank. No place it was just all blank any html page I went to. I deleted the hole spell-plugin folder then I did not get bank pages.

    This time I installed it just with the command-line here is what that looked like:

    "login as: root
    root@Small's password:
    Last login: Fri Jan 6 17:24:32 2006 from 192.168.2.3
    [root@small ~]# cd /var
    [root@small var]# cd www
    [root@small www]# ls
    cgi-bin error html icons manual usage
    [root@small www]# cd html
    [root@small html]# cd wordpress/
    [root@small wordpress]# ls
    index.php wp-commentsrss2.php wp-links-opml.php wp-rss.php
    license.txt wp-config.php wp-login.php wp-settings.php
    readme.html wp-config-sample.php wp-mail.php wp-trackback.php
    wp-admin wp-content wp-pass.php xmlrpc.php
    wp-atom.php wp-feed.php wp-rdf.php
    wp-blog-header.php wp-images wp-register.php
    wp-comments-post.php wp-includes wp-rss2.php
    [root@small wordpress]# cd wp-content
    [root@small wp-content]# ls
    index.php plugins themes
    [root@small wp-content]# wget http://coldforged.org/spell-plugin.tar.gz
    --07:28:13-- http://coldforged.org/spell-plugin.tar.gz
    => spell-plugin.tar.gz'
    Resolving coldforged.org... 64.111.99.52
    Connecting to coldforged.org|64.111.99.52|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 23,168 (23K) [application/x-gzip]

    100%[====================================>] 23,168 85.82K/s

    07:28:14 (85.57 KB/s) - spell-plugin.tar.gz' saved [23168/23168]

    [root@small wp-content]# tar xvzf spell-plugin.tar.gz
    spell-plugin/
    spell-plugin/README_INSTALL.txt
    spell-plugin/addwords.php
    spell-plugin/aspell-word-list.txt
    spell-plugin/blank.html
    spell-plugin/controlWindow.js
    spell-plugin/controls.php
    spell-plugin/netjs-devel.gif
    spell-plugin/spellChecker.js
    spell-plugin/spellInclude.php
    spell-plugin/spellchecker.html
    spell-plugin/spellchecker.php
    spell-plugin/spellerStyle.css
    spell-plugin/wordWindow.js
    plugins/spell-plugin.php
    [root@small wp-content]#"

    It all worked then. I geuss I had some files in the wrong place. I did trun off the "Use the visual rich editor when writing" in the "Users", "Your Profile"

    Thank you for the help.

    -Raymond Day

  10. rajkp
    Member
    Posted 8 years ago #

    I made a plugin for WordPress 2.0 that integrates the Speller Pages spell checker mentioned above into TinyMCE.

    Well...technically, I didn't actually write the TinyMCE plugin, I just wrote the code that integrates the spelling plugin and TinyMCE with WordPress. You can choose the language and make your own dictionary from the Options page in WordPress.

    Check it out at http://www.rajprasad.net/editormonkey/.

  11. CalEvans
    Member
    Posted 8 years ago #

  12. CalEvans
    Member
    Posted 8 years ago #

    FWIW,

    I downloaded and installed this. After figuring out the permissions issue on some of the directories I finally got FCKEdit to come up. However, the spell checker installed on my server (I am root) is aspell and the version I have must not be the one the developer coded against. It did not like many of the switches that FCKEdit was trying to pass in and even after I commented them all out, it still would not work.

    Not dissin the plugin, just sharing my experience.

    =C=
    http://blog.calevans.com

  13. rajkp
    Member
    Posted 8 years ago #

    EditorMonkey was coded for aspell 0.6 and newer. If you have an older version but shell access on your server, you can just download the newest one from the aspell site.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.