WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Spell check says Error Response: ........ (8 posts)

  1. sjtheman
    Member
    Posted 6 years ago #

    When I click Spell checker I get

    "Error response:
    <b>Warning</b>: fsockopen() [function.fsockopen]: unable to connect to http://www.google.com:443 in <b>/home/u4/myusername/html/wordpress/wp-includes/js/tinymce/plugins/spellchecker/classes/GoogleSpell.php</b> on line <b>85</b>
    Could not open SSL connection to google.{"id":null,"result":[],"error":null}"

    Without the quotations of course.

    Any Ideas

    Thanks
    SJ

  2. whooami
    Member
    Posted 6 years ago #

    is that an error that you are seeing after having just installed the plugin? Thats one one 2 or 3 things.

    1. fsockopen is disabled by your host. It often is.

    2. There's an issue with the url.

  3. sjtheman
    Member
    Posted 6 years ago #

    Thanks, I'll check that out, then get back and mark this as resolved if thats the case

    Thanks Again
    SJ

  4. sjtheman
    Member
    Posted 6 years ago #

    I got his from my hosting serivce.
    Does this make since and is this normal for a provider?
    __________________
    According to the error message, it appears that you are trying to
    connect to an outside source directories through the WordPress blog of
    yours, so you will need to specify the Outbound connection that needs to be
    allowed in that case.
    All outbound connections going off our shared hosting servers are
    filtered out by a firewall system. Our administrators review all requests
    for firewall changes per user basis.

    In order to grant access to some specific URL/IP please fill the form
    below:

    1. Specify the FTP username and domain name in question.
    2. Provide us the remote IP address and port number which needs to be
    opened (we can enable outbound connections through the ports 80 and 443
    only).
    3. Specify the local script filename and location that is running on
    our server.
    4. Explain what is the exact and detailed purpose for this connection.
    _________________________________

    Thanks again
    SJ

  5. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    You have 2 options: either use Firefox or Safari that have build-in spell checker, or provide the info so your host opens the firewall for you. All the info you need is in the error message above.

  6. phattrance
    Member
    Posted 5 years ago #

    i have a problem with the spellchecker and getting this error message:
    any ideas?

    Error response:
    <b>Warning</b>: fsockopen() [function.fsockopen]: no SSL support in this build in <b>/home/phat/public_html/wp-includes/js/tinymce/plugins/spellchecker/classes/GoogleSpell.php</b> on line <b>85</b>

    <b>Warning</b>: fsockopen() [function.fsockopen]: unable to connect to http://www.google.com:443 in <b>/home/phat/public_html/wp-includes/js/tinymce/plugins/spellchecker/classes/GoogleSpell.php</b> on line <b>85</b>
    Could not open SSL connection to google.{"id":null,"result":[],"error":null}

  7. moshu
    Member
    Posted 5 years ago #

    And did you, actually, read the responses to the initial post?

  8. Compiler
    Member
    Posted 5 years ago #

    Thanks for your help. We got the same problem with the spellchecker in our german wordpress version.

Topic Closed

This topic has been closed to new replies.

About this Topic