WordPress.org

Ready to get started?Download WordPress

Forums

MP3-jPlayer
Specifying URL for default directory not working (2 posts)

  1. RandyKing
    Member
    Posted 1 year ago #

    I wanted to load audios in a separate domain, so I created a sub-domain under the existing domain, resulting in the following:

    Main domain for website: http://www.foobar.com
    Sub-domain for audios: http://audios.foobar.com

    I loaded a few MP3s into that directory, and then tested by using the following address in my browser: http://audios.foobar.com/test.mp3 and this worked perfectly.

    However, when I put http://audios.foobar.com/ into the "Default path" setting, I get this error below the textbox:
    Unable to read or locate the folder http://audios.foobar.com check the path and folder permissions

    I tried adding a sub-directory there - no luck. I tried every combinations of URL in the textbox - no luck.

    When I put a folder "audios/" directly under my existing domain, it works just fine.

    http://wordpress.org/extend/plugins/mp3-jplayer/

  2. Deskslider
    Member
    Posted 1 year ago #

    So you solved it. Great! ;-)
    I found too that in some cases the audio has to be besides or deeper than wp-content.
    In other cases it is possible to look in folders farther away, but I lack the exact science about it.
    Sometimes even adding http:// helps.
    I'm not sure how or why, but your hosting provider or settings ca do some stuff with the url , like how they remove things like public_html when you browse, and this throws the player off. It's very picky with strings and spaces and capitals and paths. Find something that works well and move on if you can. You get a nice player in return. It's like a strong but stubborn horse I guess.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic